8

I bought a load balancer that runs the application on of FreeBSD. I found the configuration file that has all the settings and login information for both the admin and read-only users. I logged in as the root user, but when I try to alter any files using vi (the only editor installed) I get a read-only filesystem error. I tried chmod 777 file, and when I do ls -l I can see that root has read, write, and execute privileges, but it still won't let me write to the file. What do I need to do to make this file writable?

3
  • 1
    This question is kinda vague, but it sounds like you are confusing read only file permissions with a read only file system, as mschuett implies in the answer below.
    – Adam
    Commented Feb 20, 2013 at 20:38
  • You should get the documentation for the load balancer and use it with the correct interface. Trying to change things on the underlying FreeBSD layer can have disastrous effects and at the very least it will not behave as you expect. In all ways you should ignore FreeBSD as much as possible.
    – bahamat
    Commented Feb 20, 2013 at 22:07
  • It's impossible to answer this without knowing how the appliance is set up. Do you have a model number? What is the filesystem layout: post the output of mount. Where is the file you're editing located? Commented Feb 21, 2013 at 0:59

2 Answers 2

12

It's not that the file isn't writable; the filesystem itself is mounted read-only. Use mount to check the mount options and mount -u -o rw <mount_point> to remount the filesystem writable.

3
  • choose this as the correct answer
    – Nactus
    Commented Feb 1, 2017 at 16:57
  • What does -u switch do? I can't find an equivalent one in Ubuntu man page
    – sherlock
    Commented May 10, 2018 at 3:40
  • The -u flag indicates that the status of an already mounted file system should be changed. cf. the man page. As far as i know it is a BSD-specific flag to change mount options in place, without having to unmount and re-mount. -- The Linux version uses -o remount for that function.
    – mschuett
    Commented May 10, 2018 at 16:11
7

When FreeBSD boot in single-user mode, it mounts only / filesystem and mounts it in read-only mode. To access all filesystems, you should remount / in read-write mode and mount other filesystems (if any).

Screenshot from 8.4-RELEASE box:enter image description here

You must log in to answer this question.