0

I had Windows 10 installed on my Acer SF3. I tried to give it a go with Linux and made a USB stick bootable with Garuda Linux installed onto it. It installed successfully and I rebooted but the GRUB menu didn't show up despite installing with no steps missing – it directly booted into Windows 10.

I thought that the Garuda Linux was not properly installed and deleted the partition containing it, and tried booting into my USB stick again. To do that, I entered into the BIOS to change the boot priority of my USB stick to the highest. There, I saw:

  1. Windows Boot Manager

Yes, 2 was empty. I thought that 2. was the USB stick and shifted to 1.

Now, every time I boot my system it boots into "Welcome to GRUB. grub rescue>", and I can't access the BIOS.

If I reboot and press F2, it just shows a blank screen with nothing on it. And that is why I am not able to boot from my USB stick as well. I tried making the USB bootable again with Windows 10, (using another PC), but it still doesn't boot to it. Just stuck on GRUB. I watched YouTube and wrote down some commands as well. But nothing worked.

Note: The BIOS was fully working before changing the boot priority. Any help would be appreciated. How can I fix this without taking my laptop apart (I am scared).

Welcome to GRUB!

error: no such partition.
Entering rescue mode...
grub rescue> set
cmdpath=(hd0,gpt1)/EFI/Garuda
prefix=(hd0,gpt6)/@/boot/grub
root=hd0,gpt6
grub rescue> set boot=(hd0,gpt6)
grub rescue> set prefix=(hd0,gpt6)/efi/boot/grub
grub rescue> insmod normal
error: no such partition.
grub rescue> set boot=(hd0,gpt6)
grub rescue> set prefix=(hd0,gpt6)/@/boot/grub
grub rescue> insmod normal
error: no such partition.
grub rescue> set prefix=(hd0,gpt6)/boot/grub
grub rescue> insmod normal
error: no such partition.
grub rescue>
2
  • Try F10 which should allow you to select the boot drive. Well it's F10 on my system. Jun 17 '21 at 4:30
  • Possible hint: community.acer.com/en/discussion/577901/… - and as you have entered BIOS earlier I guess you know if you have to hold Fn-key down or not (IIRC one can modify that in BIOS) ... but can try both of course.
    – ibuprofen
    Jun 17 '21 at 4:44
0

Trying to access anything on (hd0,gpt6) probably does not work because that refers to the Garuda partition you said you already deleted.

You might try typing chainloader (hd0,gpt1)/EFI/Microsoft/Boot/bootmgfw.efi to the GRUB rescue prompt.

The MBR version of GRUB needs to use modules because the space for the main part of GRUB between the MBR and the beginning of the first partition may be very limited; but the UEFI version of GRUB has no such limitation. In fact if Secure Boot is in effect, UEFI GRUB must have all its functionality packaged in a single grubx64.efi binary, as the Secure Boot firmware may block it from loading any other executable code unless it has the same file format as .efi binaries and a valid signature.

In other words, if Garuda's GRUB is prepared for Secure Boot, any insmod commands in its command prompt will not work and should not be necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.