1

When I ssh into a remote server (macOS) from a Linux (Mint) laptop, the remote autocomplete engages and completes upon each keystroke. This started fairly recently, but I can't pinpoint exactly when. Once I'm successfully logged in, when I attempt to list the contents of the current directory, once I press 'l', 'ls' appears on the screen. When I type 's' to complete the list command, it now appears as 'lss' (but still executes as 'ls'). Longer commands get very weird, very fast. Typing 'exit' appears as 'exitxititt'. Again, the command still executes, but the command line is a mess.

I have no idea what's happening here--I don't even know how to ask a concise or coherent question about it. It only happens when I log into macOS from a Linux client; Linux-Linux connections are fine (all using same basic shell config; zsh using Oh-My-Zsh). Any idea what's going on? Better yet, how do I make it stop?

1
  • 1
    Do you have complete control over the remote machine? Can you try creating a new user and logging in with that user to see if you get the same issue? Can you show us the ~/.zshrc file on the mac? Do you have physical access to the mac? If yes, do you see the same thing if you log in there without ssh?
    – terdon
    Jun 15, 2021 at 8:29

1 Answer 1

0

I've figured out a simple workaround, but the problem remains unsolved. The autocomplete problem does not occur on the remote machine if I access it directly (without ssh). It also doesn't occur if I immediately change from zsh to bash once I ssh in (so it's a .zshrc issue on the macOS host--even after I turn off the zsh-autosuggestions plugin). The workaround is to simply ssh directly into bash: ssh user@host -t bash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.