1

sudo pacman -Syu returns

system is up to date
world is up to date
galaxy is up to date
::starting full system upgrade
there is nothing to do`

And then sudo pacman -S reflector returns error: target not found: reflector.

Also I get the same error when trying to install libreoffice-still.

5
  • Please edit your question and give us some context. It would also help if you could actually ask a question. I don't know if you want to know how to install this "reflector", if you want to know why you can't find it, if you want to know what it is or what. Did you try pacman -Ss reflector? What does that show?
    – terdon
    Jun 11, 2021 at 13:04
  • pacman -Ss reflector returns nothing.
    – Coelll
    Jun 11, 2021 at 13:08
  • OK, but please edit your question and address the issues I mentioned. I still don't know what you want us to help you with. Also make sure to include the commands you ran and their output in the question so people can understand. Also tell us what you have changed on your system, did this used to be installed and is now gone? Did it used to be found and now cannot be found?
    – terdon
    Jun 11, 2021 at 13:09
  • No, reflector was not previously installed on the system. I am trying to install it for the first time. And no, it could not be found previously with pacman -S.
    – Coelll
    Jun 11, 2021 at 13:48
  • mention system specifications please OS version and other details
    – FargolK
    Jun 16, 2021 at 8:38

1 Answer 1

1

Looks like you don't have the community repositories enabled. At least on my Arch system, that's where reflector is:

$ pacman -Ss reflector
community/reflector 2021.4-1
    A Python 3 module and script to retrieve and filter the latest Pacman mirror list.

I just had a look at Artix's documentation and found:

As of June 2021, all Arch repositories are disabled by default. To enable them, install artix-archlinux-support and follow the on-screen instructions to activate the Arch repositories you want, most likely extra, community and multilib, which contain packages not yet in Artix repositories. Do not enable community alone as it contains packages dependent on others in extra.

So, according to that, you should run:

sudo pacman -S artix-archlinux-support

Then follow whatever prompts that gives you to enable at least extra and community and likely also multilib. Once you have done that, run pacman -Sy to load the new sources and then you should be able to install as expected with:

sudo pacman -S reflector

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .