25

This is what I got on server:

manuel@server ~ $ cat /etc/exports
  /var/share    192.168.178.20(rw, sync)
manuel@server ~ $ cat /etc/hosts.allow 
  portmap: 192.168.178.20
manuel@server /etc $ cat /proc/filesystems | grep nfs
  nodev nfs
  nodev nfs4

This is what I get on my machine:

manuel@Timeline:~$ sudo mount -t nfs 192.168.178.2:/var/share /media/share/
   mount: wrong fs type, bad option, bad superblock on 192.168.178.2:/exports/var/share,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       Manchmal liefert das Syslog wertvolle Informationen – versuchen
       Sie  dmesg | tail  oder so

server is Raspbian (Debian Wheezy) Timeline is Ubuntu 12.04

4
  • /etc/export or /etc/exports?
    – Karlson
    Commented Feb 19, 2013 at 20:36
  • 1
    man exports. Normally filename should be /etc/exports.
    – Karlson
    Commented Feb 19, 2013 at 20:40
  • Have you changed filename on to /etc/exports?
    – Karlson
    Commented Feb 19, 2013 at 20:42
  • I just corrected it to /etc/exports. No improvement Commented Feb 19, 2013 at 20:46

4 Answers 4

36

The client needs nfs-common:

sudo apt-get install nfs-common

Refer: http://www.cyberciti.biz/faq/missing-codepage-helper-program-other-error/

12

Make sure mount.cifs, mount.nfs is listed into /sbin:

ls -l /sbin/mount.cifs
ls -l /sbin/mount.nfs

Check to see if package nfs-common, cifs-utils is installed:

dpkg -l cifs-utils
dpkg -l nfs-common

if /sbin/mount.nfs is not already there:

sudo apt-get install nfs-common

if /sbin/mount.cifs is not already there:

sudo apt-get install cifs-utils
11

Run exportfs -a on the server machine.

Also both machines have all of the needed NFS support packages and have nfs support? You can find if the kernel supports a specific filesystem by examining the output of cat /proc/filesystems.

And yes, the filename of the export file needs to be /etc/exports

Finally, check to see if you have enabled the NFS daemons during startup.

1
  • Hurray I had syntax errors in /etc/exports +1 for exportfs -a. But showmount still shows no shares. I updated the question. "Finally, check to see if you have enabled the NFS daemons during startup." - How? Commented Feb 19, 2013 at 20:53
0
busybox mount -t nfs -o nolock,nfsvers=3,vers=3 192.168.178.2:/var/share /media/share/
1
  • 3
    Welcome to Unix.SE! Could you edit your post to explain how this is supposed to solve the problem described in the question, especially in light of the accepted answer? Commented Aug 28, 2020 at 7:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .