0

I imported a virtual machine from another host (the original host is using VirtualBox 5.0.16 and the new host is using VirtualBox 6.1.12). This virtual machine is installed with RHEL 4 32-bit version and had only 1 core.

After importing it from another host I tried to increase the CPU cores to 6 cores since the new host has more core. I enabled "Nested Vt-x/AMD-V", "PAE/NX", and "I/O APIC" in the machine's settings.

After starting the VM, I checked the CPU using "cat /proc/cpuinfo" but it only displayed 1 core:

$ cat /proc/cpuinfo 
processor : 0 
vendor_id : Genuinelntel 
cpu family : 6 
model : 85 
model name : Intel(R) Xeon(R) Silver 4214 CPU 2.20GHz
stepping : 7 
cpu MHz : 2193.857 
cache size : 16896 KB 
fdiv_bug : no
hlt_bug : no
fOOf_bug : no
coma_bug : no
fpu : yes 
fpu_exception : yes 
cpuid level : 22
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht nx rdtscp constant_tsc pni popcnt 
bogomips : 4396.31 

While dmidecode type 4 doesn't show anything

$ dmidecode -t4
# dmidecode 2.9
SMBIOS 2.5 present.

I tried to use CPU hotplug and it still doesn't work.

Here's the info of the VM

4
  • Is this the stock kernel (uname -a)? RHEL 4 had some early 2.6-era kernel. Can't even say whether that thing enabled SMP out of the box. I very vaguely remember a few distros having special "linux-smp" packages that you needed to use when you wanted that, but I never used RHEL 4. Jun 9 at 9:52
  • Linux <hostname> 2.6.9-89.EL #1 Mon Apr 20 10:23:08 EDT 2009 i686 i686 i386 GNU/Linux. I'll try to look into it, thank you for the feedback. Jun 9 at 9:55
  • Please don't post images of text. Copy and paste the text itself into your question and format it as code by selecting it and pressing Ctrl-K or by using the editor's {} icon.
    – cas
    Jun 9 at 11:35
  • @cas Apologies, it's fixed. Jun 10 at 12:39
1

This source suggests there's a package called kernel-smp that you'd need.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.