3

The whole thing started like a half a year ago, when pacman started throwing 404 errors on random package downloads, thus halting the whole package installation / update process. Executing pacman -Syyu, changing the mirrors in the /etc/pacman.d/mirrorlist never solved it, though it eventually went off in a couple of days, emerging on random other packages here and there.

To clarify, I enabled different mirrors by uncommenting them (removing the #) in /etc/pacman.d/mirrorlist, choosing random mirrors from all around the world and I caught the same error on random packages, regardless of country or mirror rank.

Digging the issue, I've realized the requested package file was always version-wise older than its updated counterpart on the server (mirror): i.e. pacman requested mesa-21.1.1-1-x86_64.pkg.tar.zst as per recently updated official extra repository (namely pacman -Syy mesa) vs. mesa-21.1.2-1-x86_64.pkg.tar.zst located on the mirror, so the problem is that the repo is out-of-date rather than mirrors (vice versa would be totally understandable, as official repos are more or less centralized contrary to the decentralized mirror network), thus requesting the older version (already removed from the mirror in lieu of the more recent version) expectedly throws an 404 File Not Found error.

Is there any explanation to this issue, and is there any way to fix it?

4
  • 1
    This is completely on topic and welcome to stay here but I suspect you might get more answers on the Arch forums. That said, can you please edit your question and give us more details about "changing the mirrors in the /etc/pacman.d/mirrorlist never solved it"? That seems very strange since what you describe clearly is mirror-dependent. Can you tell us what you changed and how? I also use Arch and have never seen this, so I am guessing it's either specific to your mirrors or the packages you are installing.
    – terdon
    Commented Jun 7, 2021 at 16:32
  • @terdon Mind if I answer your question here in the comments? Mirrors are activated by commenting out (deleting the # sign) before the mirror's address in the mirrorlist file, and that was exactly what I did after stumbling upon the mentioned issue - chose random mirrors all around the world, to catch the same error upon random packages, regardless of country or mirror rank. My guess the repo sync servers are the culprit. I cannot comprehend how this might be, as the repos' updates always succeed.
    – z0mb1e_kgd
    Commented Jun 7, 2021 at 17:50
  • @tendon Just got help from bbs.archlinux.org as you suggested. It was the evowise worldwide server (relay, I guess?), that got the issue happen. I've commented it out in the mirrorlist file, updated the repos db, and the packages got updated.
    – z0mb1e_kgd
    Commented Jun 7, 2021 at 17:55
  • 1
    Great! Do you think you could post that as an answer below so the question can be marked as answered? That way, the next person with the same problem who finds your question will also see a solution. Comments are ephemeral here: they can be deleted without warning. Plus, they are hard to read, harder to format and very easy to miss. This whole system is built around questions and answers precisely to avoid needing to go through comments.
    – terdon
    Commented Jun 7, 2021 at 17:56

1 Answer 1

3

UPDATE: It was the top worldwide evowise.com server that made it happen. Just comment it in the /etc/pacman.d/mirrorlist file, and refresh the pacman db with pacman -Syyu.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .