0

I Installed VMware-Player-16.1.2-17966106.x86_64.bundle . When I ran it in the GUI it shows

I use Arch Linux and I installed all required packages as per Arch wiki . Many answers for this kind of questions are Distribution Oriented (I tried didn't work). So please anyone with same problem resolved, post an answer. Output of

pacman -Q linux 
linux 5.12.8.arch1-1

Output of

pacman -S linux-headers 


warning: linux-headers-5.12.9.arch1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) linux-headers-5.12.9.arch1-1

Total Installed Size:  129.25 MiB
Net Upgrade Size:        0.00 MiB

Even I tried replacing original tarballs of VMware (vmmon.tar and vmnet.tar in /usr/lib/vmware/modules/source/ ) with patched verson of https://github.com/mkubecek/vmware-host-modules/ github repository , As per Installation guide

When using a downloaded tarball, simply run

  tar -cf vmmon.tar vmmon-only
  tar -cf vmnet.tar vmnet-only

to create the tarballs. In this case, there is no protection against
unwanted local changes.

Whatever way you used to create the tarballs, replace the original ones
provided by VMware

  /usr/lib/vmware/modules/source/vmmon.tar
  /usr/lib/vmware/modules/source/vmnet.tar

by patched versions. It is highly recommended to backup the original
tarballs before replacing them.

Once patched tarballs are installed, you can rebuild the modules as usual:

  vmware-modconfig --console --install-all

When I run vmware-modconfig --console --install-all

[AppLoader] GLib does not have GSettings support.

(process:1887): GLib-CRITICAL **: 08:21:25.344: g_file_test: assertion 'filename != NULL' failed
Failed to setup build environment.

1 Answer 1

1

Make sure output of pacman -Q linux linux-headers match , If not perform a system upgrade using pacman -Syu so that kernel and kernel headers match. Refer to this https://wiki.archlinux.org/title/System_maintenance . After that reboot the system. It will solve the issue.

1
  • 1
    Even if linux and linux-headers are at the same version, you need to make sure that you're actually running that kernel version (uname -r must match the version of linux). If you're not: reboot.
    – Wieland
    Jun 7, 2021 at 14:31

You must log in to answer this question.