1

I'm trying to build and install the PDF viewer Atril from source in the directory $HOME/.local on a computer running Debian 10. I have issued the commands

cd "$HOME/.local/src"
apt source atril
cd atril-1.20.3
./autogen.sh
./configure --prefix="$HOME/.local"
make
make install

The last command fails with the error message

libtool: install: /usr/bin/install -c .libs/libatril-properties-page.soT /usr/lib/x86_64-linux-gnu/caja/extensions-2.0/libatril-properties-page.so
/usr/bin/install: cannot remove '/usr/lib/x86_64-linux-gnu/caja/extensions-2.0/libatril-properties-page.so': Permission denied

because libtool tries to install a library under /usr/lib. Is there an option I have missed here to make libtool honour the prefix $HOME/.local?

7
  • ./configure requires a full path: ./configure --prefix=/home/name/.local – Knud Larsen Jun 5 at 17:37
  • @KnudLarsen The environment variable $HOME expands to a full (absolute) path. – August Karlstrom Jun 5 at 17:43
  • What if you execute make clean && make && make install? – GAD3R Jun 5 at 18:50
  • 1
    @GAD3R I have tried make clean as well. I get the same error. – August Karlstrom Jun 5 at 18:59
  • 1
    It appears that configure.in is hard-wired to use pkg-config --variable=extensiondir libcaja-extension to determine the destination for caja extensions – steeldriver Jun 5 at 23:07
3

atril needs a place where to put the extensions for the caja file manager.

You can change the path in the makefile:

cajaextensiondir =

Or you can disable caja-extensions if you are not using them:

./configure --prefix="$HOME/.local" --disable-caja

Note that it will build and install, but in order to run, it also needs to find some mate stuff (that you might have already available).

4
  • I tried replacing /usr with /home/august/.local in the path defined by cajaextensiondir in Makefile but it made no difference. I get the same error message. Obviously it's ignored by the install command. – August Karlstrom Jun 6 at 8:38
  • With the option --disable-caja I can successfully install Atril. – August Karlstrom Jun 6 at 8:49
  • If I'm not mistaken the conclusion is that there is a flaw in the Atril build script since it should be possible to install any package locally in the home directory (without root privileges). It would be nice if there was an automated test which prevents packages to enter the debian repository unless this requirement is met. – August Karlstrom Jun 6 at 8:53
  • The reason I want to build Atril from source is because since a week ago or so it takes 25 seconds to launch Atril (with no document) when it used to open instantly. Now I'm trying to find out what causes the delay. When I open Atril built from source I get the same delay, so I'm good to go even without caja. – August Karlstrom Jun 6 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.