0

I installed Arch with KDE plasma. I want to start KDE without display manager and configured files by instructions from Arch wiki https://wiki.archlinux.org/title/KDE#From_the_console .But after configuring all that when I reboot it shows error and I am back to tty1 with login screen.

(II) modset(0): Initializing kms color map for depth 24,8 bpc.
(II) modset(60): Initializing kms color map for depth 24, 8bpc.
/home/user/.xinitrc: line 51: twm: command not found
/home/user/.xinitrc: line 52: xclock: command not found
/home/user/.xinitrc: line 53: xterm: command not found
/home/user/.xinitrc: line 55: exec: xterm: not found
/home/user/.xinitrc: line 54: xterm: command not found
xinit: connection to X server lost
waiting for X server to shut down (II) server terminated successfully (0). Closing log files.

My .xinitrc file

#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then







    xrdb -merge $sysresources

fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f "$userresources" ]; then







    xrdb -merge "$userresources"

fi

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"
fi

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 done
 unset f
fi

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
export DESKTOP_SESSION=plasma
exec startplasma-x11

My .xserverrc file

#!/bin/sh
exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR`

My .bash_profile

#
# ~/.bash_profile
#

[[ -f ~/.bashrc ]] && . ~/.bashrc
if [ -z "${DISPLAY}" ] && [ "${XDG_VTNR}" -eq 1 ]; then
   exec startx
 fi

All these files are in /home/user . What am I doing wrong? Thanks!

0
1

The error tells you what's wrong:

Fatal server error:(EE) Unrecognised option: Vt1

Most things in Unix are case sensitive, in this case, you need to change your .xserverrc file to use the option vt (instead of Vt, note the lowercase v).

#!/bin/sh
exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR`
5
  • Trapani Yeah, But after changing that I get another error. Posted Above.
    – user476067
    Jun 5 at 6:41
  • I don't see any other error in your question ... Jun 5 at 6:43
  • I should have commented after the edit, sorry!
    – user476067
    Jun 5 at 6:56
  • 1
    That's another problem. Note that people here will gladly help with an issue, but will not walk you through a tutorial (that is actually off-topic). In this case though, your PATH is probably not set or you didn't install the software. Change xterm with the full path /usr/bin/xterm (or install xterm for example if you haven't). The same applies for the other "not found" errors. If the original issue was solved, then please mark this as solved (for those seeking help with the same error). And feel free to post a new question if something doesn't work, after you research the problem. Jun 5 at 7:03
  • @ Eduardo Trapani , Thanks I solved the issue . It is ttwm & xclock -geometry 50x50-1+1 & xterm -geometry 80x50+494+51 & xterm -geometry 80x20+494-0 & exec xterm -geometry 80x66+0+0 -name login should be removed from .xinitrc file so that it executes plasma.
    – user476067
    Jun 5 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy