I installed Arch with KDE Plasma. I want to start KDE without a display manager and configured files by following the instructions from KDE - ArchWiki, but after configuring all that when I reboot it shows an error and I am back to tty1 with login screen.

(II) modset(0): Initializing kms color map for depth 24,8 bpc.
(II) modset(60): Initializing kms color map for depth 24, 8bpc.
/home/user/.xinitrc: line 51: twm: command not found
/home/user/.xinitrc: line 52: xclock: command not found
/home/user/.xinitrc: line 53: xterm: command not found
/home/user/.xinitrc: line 55: exec: xterm: not found
/home/user/.xinitrc: line 54: xterm: command not found
xinit: connection to X server lost
waiting for X server to shut down (II) server terminated successfully (0). Closing log files.

My .xinitrc file



# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
 for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
  [ -x "$f" ] && . "$f"
 unset f

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login
export DESKTOP_SESSION=plasma
exec startplasma-x11

My .xserverrc file:

exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR`

My .bash_profile:

# ~/.bash_profile

[[ -f ~/.bashrc ]] && . ~/.bashrc
if [ -z "${DISPLAY}" ] && [ "${XDG_VTNR}" -eq 1 ]; then
   exec startx

All these files are in /home/user .


1 Answer 1


The error tells you what's wrong:

Fatal server error:(EE) Unrecognised option: Vt1

Most things in Unix are case sensitive, in this case, you need to change your .xserverrc file to use the option vt (instead of Vt, note the lowercase v).

exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR`
  • Trapani Yeah, But after changing that I get another error. Posted Above.
    – user476067
    Jun 5, 2021 at 6:41
  • I don't see any other error in your question ... Jun 5, 2021 at 6:43
  • I should have commented after the edit, sorry!
    – user476067
    Jun 5, 2021 at 6:56
  • 1
    That's another problem. Note that people here will gladly help with an issue, but will not walk you through a tutorial (that is actually off-topic). In this case though, your PATH is probably not set or you didn't install the software. Change xterm with the full path /usr/bin/xterm (or install xterm for example if you haven't). The same applies for the other "not found" errors. If the original issue was solved, then please mark this as solved (for those seeking help with the same error). And feel free to post a new question if something doesn't work, after you research the problem. Jun 5, 2021 at 7:03
  • @ Eduardo Trapani , Thanks I solved the issue . It is ttwm & xclock -geometry 50x50-1+1 & xterm -geometry 80x50+494+51 & xterm -geometry 80x20+494-0 & exec xterm -geometry 80x66+0+0 -name login should be removed from .xinitrc file so that it executes plasma.
    – user476067
    Jun 5, 2021 at 7:51

You must log in to answer this question.