0

Solved, but currently I'm not allowed to mark my own answer as the accepted answer.

I bought a new system and want to install promox ve on it. Unfortunately the instllation process is not able to get an network connection. After some research I found that this is an issue with the NIC of my mainboard (more later). One solution should be to install debian buster, the network driver and when the network connection works installing proxmox ve. But I got stuck on installing the driver.

Mainboard: ASRock B550
-> NIC: RTL8125BG
-> Driver: 2.5G Ethernet LINUX driver r8125 for kernel up to 5.6
CPU: Ryzen 4650G

Some information about the os:

$ lsb_release -a
Distributor ID: Debian
Description:    Debian GNU/Linux 10 buster)
Release:        10
Codename:       buster

$ uname -v
#1 SMP Debian 4.19.181-1 (2021-03-19)

$ lshw -C network
  *-network UNCLAIMED
      description: Ethernet controller
      product: Realtek Semiconductor Co., Ltd.
      vendor: Realtek Semiconductor Co., Ltd.
      physical id: 0
      bus info: pci@0000:06:00.0
      version: 05
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress msix vpd bus_master cap_list
      configuration: latency=0
      resources: ioport:f0000(size=256) memory:fce00000-fce0ffff memory: fce100000-fce13fff

To have an temporary network connection I used my smartphone and enabled the USB tethering option. This worked fine for the installation process and running debian, but not for the pve installation process.

This way I was able to download the driver and install build-essential (and packages like lshw).
But installing the driver fails when building the module.

$ ./autorun.sh

Check old driver and unload it.
Build the  module and install
make[2]: *** /lib/modules/4.19.0-16-amd64/build: No such file or directory. Stop.
make[1]: *** [Makefile:176: clean] Error 2
make: *** [Makefile:48: clean] Error 2

When creating the missing build directory it still fails

$ mkdir /lib/modules/4.19.0-16-amd64/build
$ ./autorun.sh

Check old driver and unload it.
Build the  module and install
make[2]: *** No rule to make target 'clean'. Stop.
make[1]: *** [Makefile:176: clean] Error 2
make: *** [Makefile:48: clean] Error 2

Any ideas what I'm missing to install that driver?

1
  • 2
    RTL8125B is supported by firmware-realtek from backports. I'd try the current kernel and firmwares (including firmware-realtek) from buster-backports. Instructions here. – Freddy Jun 4 at 23:00
0

Even if I installed build-essential there were some files missing.
Installting linux-headers-4.19.0-16-amd64 fixed my problem!

After running $ apt install linux-headers-4.19.0-16-amd64 I was able to install the driver and configure the interface.

If you have the same issue, you have to adjust the kernel version in the package


UPDATE (PVE)
The pve installation includes a new kernel.
To rebuild the network driver I had to install pve-headers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.