0

I am using remote desktop on a windows machine to connect to a CentOS 7 machine running a Xrdp server. Recently I had a problem with an application, where the avaialable openGL version (2.1) was not enough and it suggested either updating it, or using VNC.

While trying to make a VNC connection to work I made several updates inlcuding a Kernel update. I could not get the turboVNC to work at the same time than Xrdp, and damaged the settings somehow.

Now, when I connect to the Xrdp session the Gnome shell window is very small and has a weird aspect ratio, making it unusable (see picture below, the black area is the the size of my screen). Even if logged out of the gnome session, where I am able to select other shell (KDE, for example) I still have the same window size. enter image description here

Since I could not find a similar problem, I am not sure what is causing the problem. How could I return the size of the window to its original shape and size?

2
  • The first place you should be looking is the default.rdp file on you MS-Windows client.
    – symcbean
    Jun 3 '21 at 21:30
  • I do not think it has something to do with the MS-Windows client. I also have access to another workstation where I do not have this problem. Since I am using a ssh-tunel and connecting to localhost:port, I do not need to change the configurations in the remote desktop, so that the same setting applies for both machines.
    – thomaseh
    Jun 4 '21 at 7:07
0

Centos 7.9 target- same issue but with Mate GUI. Restarting the xrdp service on the target worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.