Here I described trouble installing pulseaudio due to mismatching dependencies when using packages of Kodi19 on Debian10. This is now resolved insofar that after a recent upgrade I was able to install pulseaudio and get it running via this command: sudo apt-get install pulseaudio/buster-backports libpulse0/buster-backports libasound2-plugins.

My problem now is that the audio output still isn't working even though pulseaudio is running. I tried some changes to client.conf, daemon.conf and default.pa as described here and here. It still doesn't work. I didn't have this problem before the audio stops working. I recently noticed the sound output actually still does work (for local audio files) but only over headphones (and then there's still no volume icon in the tray bar etc).

How to get audio output working again? If changes to the config files are needed how to find out which changes are required? Any ideas about why this problem occurred?

Running pulseaudio -k didn't restart pulseaudio.
The audio output still worked for online streaming even before pulseaudio was installed.

Another Debian10/KDE machine with almost the same setup including Kodi19 doesn't have this problem.

Once pulseaudio works there should be a volume-icon in the tray bar and the volume-buttons should work again.

There shouldn't be any need to change configs to get audio working after installing pulseaudio (which should never have been removed anyway as I didn't deliberately remove it).

I also have e.g. gstreamer1.0-pulseaudio installed. When I search for "pulse" "Audio Volume" is not showing upl in the search results like on another machine so maybe I need to install some additional package. Or maybe I need to clear some configs.

When I run pulseaudio in the console because it doesn't get restarted after running pulseaudio -k I get Failed to load module "module-native-protocol-unix" (argument: ""): initialization failed. (it does start it nevertheless).

One other thing that might have to do with it, is that running an upgrade with apper or sudo apt-get upgrade asks me to downgrade libwayland-client++0 libwayland-cursor++0 which appears to work but even after rebooting it still asks for the same two downgrades. This was solved by rerunning the setup steps for Basil Gello's repo.

1 Answer 1


It worked once new packages were available and could be upgraded. Maybe it was a problem with mismatching packages of Basil Gello's repo which isn't needed anymore as those Kodi things moved into backports.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .