Have had WiFi working fine via wifi-menu on command line for a while, but would much prefer the gnome icon, so i switched to NetworkManager, and now nothing will connect. I enabled my dhcp daemon in the config file, but the issue seems to happen before that point... any network I try it just refuses to connect to. It sees networks, then fails to connect immediately on click.

4 Answers 4


Straight from the Arch Linux Wiki page on NetworkManager.

If NetworkManager is going to be handling any/all network devices. Then you should not have anything but NetworkManager enabled. If you have any net-auto-wireless services enabled they will have to be disabled.

# systemctl stop net-auto-wireless.service

# systemctl disable net-auto-wireles.service

You will then have to bring down your Network Interface Controllers. If you're using the new naming scheme then use ip l to display the interface names and bring them down.

For each interface listed (wired, wireless):

# ip link set <interface> down

Once down, enable NetworkManager and start NetworkManager:

# systemctl enable NetworkManager

# systemctl start NetworkManager

Note: If you have services which fail if they are started before the network is up, you have to use NetworkManager-wait-online.service instead. This is however hardly ever necessary since most network daemons start up fine, even if the network has not been configured yet.

Also: I believe extra/networkmanager does not supply the gnome applet. If not it will be in extra/network-manager-applet

# pacman -Syu networkmanager network-manager-applet

  • 2
    -1 for copying from arch wiki without referencing it. Plagiarism in small. Commented May 9, 2013 at 0:22
  • The first sentence is weird... If it means to say "any", why include "all"?
    – lindhe
    Commented Sep 25, 2015 at 16:15

First stop NetworkManager and anything that has to do with networking:

# systemctl stop NetworkManager

pgrep -l dhc (stop the services or kill the processes for these)

ps aux | grep -i wicd | grep -v grep (same with these)

Then start NetworkManager again, and wait for a few seconds.

# systemctl start NetworkManager

Use the network-manager-applet if you like. See if you can connect.


I had the same problem and have tried all suggestions on the net but in the end it was enough to install dhclient to solve my problem.

  • I don't know why you downvoted this answer, actually it solved my problem too.
    – aliva
    Commented Oct 12, 2013 at 7:50

Sometimes, NetworkManager doesn't prompt you to enter the password for protected network. If you're trying to connect to a protected network, edit the network from GNOME Control Center and set the network's password. Then, connect to the network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .