I'm using VirtualBox OSE and recently, when I run Ubuntu 10.10 on it, my machine tends to hang, forcing me to hard-reset it (not good). How do I start finding where the problem is?

Here's the last line from "/var/log/syslog", before the reset:

Jan 27 12:11:22 debian kernel: [  193.400230] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)


  • VirtualBox OSE is version 3.2.10
  • I use 32-bit 2.6.37 kernel on Debian Squeeze
  • I can't reproduce this problem when using Fedora 14 VM
  • 3
    If the kernel crashes, the system often won't have time to handle the relevant log messages. See How can I get a Kernel Core Dump and Kernel Netconsole for advice on debugging kernel panics on Ubuntu, you may be able to adapt it to Debian. – Gilles 'SO- stop being evil' Jan 27 '11 at 19:29
  • Please post further logs, specifically the /var/log/messages – Šimon Tóth Feb 1 '11 at 12:09
  • Do you get it with virtualization extensions both on and off? – Thomas Feb 8 '11 at 17:15
  • @thomas what is that? – tshepang Feb 8 '11 at 18:01
  • 2
    @Tshepang: In Settings > System > Process/Acceleration, there are various settings to enable/disable virtualization extensions (if available in the hardware). These include PAE/NX, VT-x, etc. ~ en.wikipedia.org/wiki/… – Thomas Feb 8 '11 at 18:33

I've also experienced hard crashes when having a good amount of disk activity both in the VM and on the "native" system. The system was rock-stable when not using a VM, even under heavy loads. I tried new kernel versions and new versions of VirtualBox, but the problem persisted. Then I switched to a newer computer (an i7), which did not have the same problem. However, the computer with the problems got worse, and started crashing in other situations as well. Now it does not even boot, but freeze while in the BIOS stage of the boot process. It may be a hardware issue and/or problems with the VM-instructions on the CPU.

You could try to limit IO and/or the number of CPUs used from the VM, and see if it helps.

|improve this answer|||||
  • What you are describing has nothing to do with VirtualBox. If the host system kept crashing and is not even booting anymore now, you have bad hardware. In such a case, VirtualBox would only trigger (not cause) a crash. Try running memtest. And be careful, bad memory can cause a lot of data corruption. – basic6 Jan 5 '15 at 0:05
  • If the virtualization instructions of the CPU were used and were the root of the problem, it would not be the fault of VirtualBox, but not completely unrelated either. That computer is long gone (and memtest revealed nothing). – Alexander Jan 5 '15 at 9:56

this is a shot in the dark, but we used to have these inexplicable issues with virtual box in connection with using bridged networking and offloading. Try

ethtool -K eth0 tx off

this should be fixed in the 4.x series as far as I know.

|improve this answer|||||

I had the problem with the netcard freezing VirtualBox: When I accessed it through the GUI the VM was up and running, however, the netcard driver had crashed.


My work-around was to ping the VM from the host. If its network was down: Reboot it.

Maybe it is the same issue?

|improve this answer|||||
  • My problem was worse than that. My host got frozen, not just the guest. – tshepang Jun 20 '11 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.