2

My debian is not starting well and go to emergency mode (with no possibility to avoid it :-(). In order to login, I need to be able to type my root password which contains special characters like é. How can I obtain these characters? I tried to go on grub console to try to type but I was not able to obtain the right characters...

4
  • Try this link - It also has links for how to find special characters.
    – Dave White
    Jun 2, 2021 at 14:38
  • 2
    ... and be nicer to yourself, instead of using special characters such as diacriticals in a root password, which you know might be required when emergency dropping to console, just use a longer pure ascii password. Just saying...
    – Cbhihe
    Jun 2, 2021 at 15:01
  • And since you've now publicly discussed a password, changing it would be a good idea. :) Any possible security implications of using special characters are now negated, and a longer ascii password would be as secure or more secure.
    – user10489
    Jun 2, 2021 at 16:30
  • @user10489 Your right :-) and I will actually not using special characters not available directly in a US/UK keyboard layout
    – Guuk
    Jun 2, 2021 at 19:18

1 Answer 1

0

At the console you can use Altxyz (xyz are number on the numpad).

For example Alt233 should render é.

There are many sources for the list of codes, for example this one.

I don't know if it will work though, because depending on the locale, the actual password characters could be UTF-8 for example.

5
  • Are you sure about this? I can't reproduce this at all. Could it depend on your keyboard layout? I tried both in a tty and in a graphical terminal and nothing worked.
    – terdon
    Jun 2, 2021 at 15:02
  • FWIW, using my left alt key I get one character, using the right alt key I get the correct one. For both of these situations I have to use the numpad, the normal numbers don't work.
    – cutrightjm
    Jun 2, 2021 at 15:05
  • Thanks @cutrightjm I should've mentioned the numpad. Added. Jun 2, 2021 at 15:09
  • @terdon I know it works in my Debian 10, after doing Ctrl-Alt-F1 (no, it will not work inside a graphic terminal). Jun 2, 2021 at 15:09
  • Thank you for your proposition but currently it is not working. Probably because I use an apple keyboard...
    – Guuk
    Jun 2, 2021 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.