0

I used these directions to setup Private Internet Access (PIA) VPN for my Raspberry Pi 4. I'm running Raspbian, and using the Pi as a mini desktop computer attached to my TV. And I'd like to have a VPN connection to avoid sharing my IP. Unfortunately, my IPv6 is still being broadcast. So I used these instructions to disable IPv6.

Unfortunately, when running sudo openvpn ca_vancouver.ovpn, I still get the following error:

Tue Jun  1 07:49:22 2021 WARNING: file 'auth.txt' is group or others accessible
Tue Jun  1 07:49:22 2021 OpenVPN 2.4.7 arm-unknown-linux-gnueabihf [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Feb 20 2019
Tue Jun  1 07:49:22 2021 library versions: OpenSSL 1.1.1d  10 Sep 2019, LZO 2.10
Tue Jun  1 07:49:22 2021 TCP/UDP: Preserving recently used remote address: [AF_INET]208.78.42.222:1198
Tue Jun  1 07:49:22 2021 UDP link local: (not bound)
Tue Jun  1 07:49:22 2021 UDP link remote: [AF_INET]208.78.42.222:1198
Tue Jun  1 07:49:22 2021 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Tue Jun  1 07:49:22 2021 [vancouver412] Peer Connection Initiated with [AF_INET]208.78.42.222:1198
Tue Jun  1 07:49:23 2021 OpenVPN ROUTE6: OpenVPN needs a gateway parameter for a --route-ipv6 option and no default was specified by either --route-ipv6-gateway or --ifconfig-ipv6 options
Tue Jun  1 07:49:23 2021 OpenVPN ROUTE: failed to parse/resolve route for host/network: 2000::/3
Tue Jun  1 07:49:23 2021 TUN/TAP device tun0 opened
Tue Jun  1 07:49:23 2021 /sbin/ip link set dev tun0 up mtu 1500
Tue Jun  1 07:49:23 2021 /sbin/ip addr add dev tun0 10.32.112.52/24 broadcast 10.32.112.255
Tue Jun  1 07:49:23 2021 WARNING: OpenVPN was configured to add an IPv6 route over tun0. However, no IPv6 has been configured for this interface, therefore the route installation may fail or may not work as expected.
Tue Jun  1 07:49:23 2021 Initialization Sequence Completed

More so, when trying to browse to any website in Chromium, I get the following error (in this case I'm trying www.privateinternetaccess.com):

This site cant be reached www.privateinternetaccess.com. Server IP address could not be found.
Error: DNS_PROBE_FINISHED_BAD_CONFIG

Any advise or support available to help resolve this problem while blocking my IPv6?

1 Answer 1

0

Try these steps if your Ipv6 isn't actually getting disabled:

Temporarily disable IPv6

to see if OpenVPN with PIA connects as expected:

sysctl -w net.ipv6.conf.all.disable_ipv6=1

Then connect to PIA.
if that works then:


Permanently disable IPv6.

Step 1:

Add this to your kernel line in /boot/cmdline.txt to disable IPv6 altogether:

ipv6.disable=1

Note:* this requires a reboot


Step 2:

To disable ipv6, you have to open /etc/sysctl.conf using any text editor and insert the following lines at the end:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

and reboot. If IPv6 is still not disabled, then the problem is that sysctl.conf is still not activated. To solve this, type the command:

sudo sysctl -p

You will see this in the terminal:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

After that, if you run:

cat /proc/sys/net/ipv6/conf/all/disable_ipv6

taken from this guide.

6
  • Thanks - unfortunately after temporarily disabling IPv6, I get the same result (mind you, it looks like Open VPN is sort of successful but when I try and visit a website in my browser I get the same DNS related error).
    – bpdronkers
    Jun 1, 2021 at 14:58
  • Is this in Chrome? Try this command nslookup google.comand post the output
    – Shōgun8
    Jun 1, 2021 at 15:14
  • You could also try this script gist.github.com/catchdave/f13650c981576a7cabc9
    – Shōgun8
    Jun 1, 2021 at 15:22
  • nslookup doesn't exist as command. I used 'host google.com' while VPN is running (with those error codes above) and the output is simply "connection timed out: no servers could be reached". If I Control-C the terminal window with the VPN (killing it) then I get a bunch of replies (e.g. google.com is handled by ...).
    – bpdronkers
    Jun 1, 2021 at 15:39
  • Is it some issue with DNS (I know very little about this stuff so I apologize for seeming to be incompetent!)
    – bpdronkers
    Jun 1, 2021 at 15:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .