0

On Ubuntu MATE 20.04, which I use as a live TV laptop OS, there seems to be a problem with some settings, upon which the screensaver is run or the screen turns off; I don't know if both apply, or which one.

What is the goal:

  • To disable the screensaver forever or generally leave the screen on all the time.

  • I normally ssh to this machine, so I prefer script or command solutions.

What I did already: I looked everywhere in the standard settings, but no clue, nor any solution.

0

Autostart script solution

Before you start reading, make sure, that in your Power Management preferences the display is set to Never to be put to sleep when inactive.


So, I did a lot of digging, and thanks to the official forum (source link) I got my answer:


Place the below script to this location:

~/.config/autostart/

Script:

#!/bin/sh
sleep 10 && xset -dpms s off s noblank s 0 0 s noexpose

Obviously, you can name it to your liking, e.g. disable_screensaver and you need to chmod 775 it.

Note, that the sleep 10 can be adjusted to how fast your desktop loads, mine is slow, so...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.