so I've cloned this github repository https://github.com/xiangzhai/rt5370 It's a drive for my wifi adapter. My problem is that whenever I try to use the "make" command, it returns this error

/lib/modules/5.3.7-gentoo--g243aa7022-dirty/build No such file or directory 

This is what I've tried so far

emerge --sync

emerge linux-header

emerge build

No luck, could anyone help me please I've been trying to fix the issue for hours now

  • type the command which build, or emerge --info | grep build
    – Shōgun8
    Commented May 29, 2021 at 9:22
  • Which build outputted that it hadn't found it
    – EDllT
    Commented May 29, 2021 at 9:52
  • As for the emerge info grep build it outputted this FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
    – EDllT
    Commented May 29, 2021 at 9:53
  • Usually /lib/modules/{kernel-version}/build is a symbolic link to the source directory that was used to build those modules. For example /lib/modules/5.10.27-gentoo/build -> /usr/src/linux-5.10.27-gentoo/ It looks like you're missing that build directory. Commented Jun 6, 2021 at 1:15

2 Answers 2


Maybe a header issue?

ln -s /usr/src/linux-headers-5.3.7-gentoo--g243aa7022-dirty/ /lib/modules/5.3.7-gentoo--g243aa7022-dirty/build

emerge linux-headers-$(uname -r)
  • None worked I've tried the first one, it said that it didnt match anything This ./configure && make && sudo make install and this ./autogen.sh && make && sudo make install returned an error saying that ./configure and ./autogen.sh weren't found respectively
    – EDllT
    Commented May 29, 2021 at 10:35
  • did you modify the file os/linux/config.mk? What is the output of ls /usr/src/linux-headers*
    – Shōgun8
    Commented May 29, 2021 at 12:21
  • I haven't edited os/linux/config.mk when I do the ls thing it outputs ls cannot access /usr/src/linux-headers* no such file or directory I tried removing the * still the same output
    – EDllT
    Commented May 29, 2021 at 21:26
  • How about this: sudo find / -name linux-headers*?
    – Shōgun8
    Commented May 30, 2021 at 4:51
  • It returned a bunch of results inside /usr/portage/sys-kernel/linux-headers-5.12 and/var/db/pkg/sys-kernel also /var/cache/edb/dep/usr/portage and so on
    – EDllT
    Commented May 30, 2021 at 5:21

Apparently my kernel wasn't actually compiled. Compiling my kernel fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .