I am using Arch linux. Currently, I am having the trouble of:

User Login Management failed
User Login Management failed
User Login Management failed
User Login Management failed
Kernel Module drm failed
Hostname Service failed


I tried rescue shell and chrooting, but even though I was able to login as user or root, I was not able to install any packages. I am getting permission denied error. Although, it is able to connect to repositories and see which packages need to be installed.

I do not know the cause of this, it happened after a restart. When the computer starts, all I get is a black screen with a cursor. Cannot even change ttys, all I get is blinking underscore.

hostnamed.service error is:

Operation not permitted
Failed with result resources

logind.service error is the same.

One thing about hostnamed.service journal is at some point before, it states as

D-Bus name org.freedesktop.hostname1 now not owned by anyone.

I don't know what it means.

When I mask these 2 services, it doesn't show any errors, but I still get black screen with cursor, without being able to login.

I still do not have any idea why root is able to connect to repositories, but not able to have permissions to var/cache/pacman....

When I try, start sddm, I still get black screen with cursor.

How can I solve this problem? Thanks.

  • Did you try su?
    – user449077
    May 27, 2021 at 12:32
  • I tried su - and su - user, same result.
    – Quagmire
    May 27, 2021 at 17:06

1 Answer 1


The root filesystem is usually mounted read-only in rescue mode. Running the command below (the awk bit filters out information for only the root FS):

# mount | awk '$3 == "/"'
/dev/vda4 on / type xfs   

Should show (ro...) in your case if it is mounted in read-only mode.


# mount -oremount,rw /

then the commands.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .