0

I run opensuse Leap-15.2 with the kernel 5.3.18 on Lenovo ThinkPad X1 Yoga Gen 5. I experience problems configuring sound card Intel Comet Lake PCH-LP cAVS. Configuring sound using yast2-gui results in the message

The kernel module snd-soc-skl for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

Partial output of lspci -vv is below

00:1f.3 Audio device: Intel Corporation Comet Lake PCH-LP cAVS (prog-if 80)
        Subsystem: Lenovo Device 22be
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 64
        Interrupt: pin A routed to IRQ 141
        Region 0: Memory at ea33c000 (64-bit, non-prefetchable) [size=16K]
        Region 4: Memory at ea000000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [80] Vendor Specific Information: Len=14 <?>
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee004b8  Data: 0000
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel, snd_soc_skl, sof_pci_dev

Hardware profile of the machine is at https://linux-hardware.org/?probe=e40b11dca2

I will greatly appreciate any help configuring the device.

1 Answer 1

0

This is my first response I've written on this site. As someoenter code herene that has to compile my own kernel (Gentoo user here) when I have this error, I recompile the kernel modules.

Here's the output of my sound card:

00:1f.3 Multimedia audio controller: Intel Corporation Comet Lake PCH-LP cAVS
Subsystem: Hewlett-Packard Company Comet Lake PCH-LP cAVS
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 165
Region 0: Memory at 6043118000 (64-bit, non-prefetchable) [size=16K]
Region 4: Memory at 6043000000 (64-bit, non-prefetchable) [size=1M]
Capabilities: [50] Power Management version 3
    Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
    Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [80] Vendor Specific Information: Len=14 <?>
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Address: you shouldn't publicize this information
Kernel driver in use: sof-audio-pci
Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci

Also noticed my system uses snd_sof_pci instead of your sof_pci_dev, don't know the difference between the two but perhaps sof_pci_dev is "leading edge"

1
  • Thanks. I have recompiled the kernel sometime ago and everything works now.
    – R. Matveev
    Commented Aug 3, 2021 at 10:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .