0

First, I encountered the error below when trying to install new packages.

sudo apt-get install mpack   
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Suggested packages:
  mail-transport-agent inews
The following NEW packages will be installed:
  mpack
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 36.4 kB of archives.
After this operation, 93.2 kB of additional disk space will be used.
Err:1 http://http.kali.org/kali kali-rolling/main amd64 mpack amd64 1.6-8.2
  404  Not Found [IP: 192.99.200.113 80]
E: Failed to fetch http://http.kali.org/kali/pool/main/m/mpack/mpack_1.6-8.2_amd64.deb  404  Not Found [IP: 192.99.200.113 80]

This is just one example from many packages I'd tried to install. They all failed with the same error (fetching old-non-existent package version)

I noticed that the error said that I could not access to "http://http.kali.org/kali/pool/main/m/mpack/mpack_1.6-8.2_amd64.deb" (on the last line)

So, I tried to access the URL directly on the browser and got 404 not found. What I did next was I went back one step on the URL, so I went to "http://http.kali.org/kali/pool/main/m/mpack/" and found that there was no this "mpack_1.6-8.2_amd64.deb" version. The file that my kali should fetch is "mpack_1.6-17_amd64.deb" (it is there on the mpack path)

I confirm that I have a correct sources.list file and did run the apt update.

my sources.list contains these 2 lines which should be correct and should not be the problem here.

deb http://http.kali.org/kali kali-rolling main non-free contrib
deb-src http://http.kali.org/kali kali-rolling main contrib non-free

The commands that I ran so many times are:

apt update
apt-get update
sudo apt update
sudo apt-get update

So I was so confused why my kali still keeps fetching the old package that it does not exist, and throws the error 404 not found to me?

Or has anybody encountered the same problem?

sudo apt update result:

$ sudo apt update
Get:1 http://mirror.kku.ac.th/kali kali-rolling InRelease [30.5 kB]
Get:2 http://mirror.kku.ac.th/kali kali-rolling/non-free Sources [135 kB]
Get:3 http://mirror.kku.ac.th/kali kali-rolling/main Sources [12.7 MB]
Get:4 http://mirror.kku.ac.th/kali kali-rolling/contrib Sources [63.7 kB]
Get:5 http://mirror.kku.ac.th/kali kali-rolling/main amd64 Packages [17.1 MB]
Get:6 http://mirror.kku.ac.th/kali kali-rolling/main amd64 Contents (deb) [36.3 MB]
Get:7 http://mirror.kku.ac.th/kali kali-rolling/contrib amd64 Packages [105 kB]
Get:8 http://mirror.kku.ac.th/kali kali-rolling/contrib amd64 Contents (deb) [105 kB]
Get:9 http://mirror.kku.ac.th/kali kali-rolling/non-free amd64 Packages [188 kB]
Get:10 http://mirror.kku.ac.th/kali kali-rolling/non-free amd64 Contents (deb) [911 kB]
Fetched 67.7 MB in 8s (8,332 kB/s)                                                                                                                                                                                 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
7
  • 1
    @GAD3R thank you for your answer. I did what you suggested but mpack version is still 1.6-8.2
    – answer
    May 23 at 19:01
  • Can you add to your question the full output of apt-get update? May 23 at 19:29
  • Is your time set correctly? Also, is this IP address 192.99.200.113 the IP address of the machine you're trying to update? It seems odd that apt would claim be tryng to connect to the HTTP server at this address: 404 Not Found [IP: 192.99.200.113 80]. When I dial in that address I get Debian Apache Sefver - it works!. I that's your IP address that you're trying to update - try shutting down the Apache server and see it that helps. May 23 at 20:30
  • @EduardoTrápani Hello Eduardo, I've just updated the apt update result in the question. Looks like my kali connected to the "mirror.kku.ac.th" domain rather than "http.kali.org". Is this behaviour normal?
    – answer
    May 24 at 14:00
  • 1
    It can be a normal thing if you are using mirrors. May 24 at 14:03
2

The http://mirror.kku.ac.th/kali mirror is outdated, providing the old version mpack_1.6-8.2. You can choose a different mirror from Kali Mirrors.

Use the following commands:

printf "%s\n" "deb http://mirror.easylee.nl/kali/ kali-rolling main non-free contrib" |\
sudo tee /etc/apt/sources.list
sudo apt update
sudo apt install mpack
2
  • OH GOD! IT WORKS! You are a life saver! I thank you four thousand. Anyways, can you tell me how did you know that the mirror is outdated and what is the best mirror to use?
    – answer
    May 25 at 16:52
  • @answer You can check the package version and the last update here mirror.kku.ac.th/kali//pool/main/m/mpack
    – GAD3R
    May 25 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.