3

I tried running Darktable (version 1.0.4-1~bpo60+1 from Debian Squeeze-backports) under Xfce, but I am using a fairly light "Style" theme in Xfce which Darktable didn't work too well with. It seems to do some magic to set specific colors in GTK/GNOME dialogs (the file open dialog for "import" being one example), and the two clash resulting in nearly unreadable file listings.

When I switched to a darker theme (I tried Xfce-dusk, but others worked similarly well), the colors aligned and usage was much smoother. However, I'd rather not switch to a dark color theme just for this one application, and I don't see any obvious way of switching Darktable to a lighter color theme.

I did find mention of the GTK2_RC_FILES environment variable (set it to the full path to a gtkrc), which seems to work for e.g. gedit (GTK2_RC_FILES=/usr/share/themes/HighContrastLargePrintInverse/gtk-2.0/gtkrc gedit works quite nicely and only affects that instance) but it does not seem to have any effect for Darktable. Since changing the global theme does work, there's obviously some way to make this work. So what other magic is needed?

0

The answer by @WalDo does have its merit: it suggests where to look. The solution which does work is putting your own gtkrc to ~/.config/darktable/, but under the same name as the system-wide one: darktable.gtkrc. Here's how I did it:

ln -sv ~/.gtkrc-2.0 .config/darktable/darktable.gtkrc

After this command my Darktable 1.4 does follow my chosen style Oxygen-GTK2.

This answer is going to soon become obsolete though, since Darktable seems to be switching to GTK3, and GTK3 has its own complications with themes, but you might be able to point Darktable to your own gtk3.css and have some success.

-1

Try to edit /usr/share/darktable/darktable.gtkrc (system wide) or copy that file to ~/.config/darktable/darktablerc (user preferences)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.