4

I'm having a somewhat frequent and incredibly annoying problem with Fedora workstation. Every so often the desktop completely stops responding to any inputs from a mouse button (the cursor is still visible and moves) and I can no longer change focus of the active application. This happens completely randomly and can happen after I've left the computer for an hour during lunch or after 5 minutes while I was using some application. I can't see any pattern.

For example, let's say I've been working in libre office for a while and I switch to firefox to search for something, when I go to switch back to libre office the mouse has completely stopped working and clicking on any window, dock, taskbar, etc leads to nothing. I can usually alt-tab to a different application as the keyboard stays functioning, but the application I try switching to remains hidden in the background. Any keyboard input I make is for the active application I've switched to and seems to be accepted, I just can't see what I'm doing because it's hidden behind the previous app window. The only thing that works is the application I was using when the problem occurred e.g. the firefox window that is on top and I have to alt-tab back to this application to use it with the keyboard input. Once back in firefox, the mouse will work on the internal GUI elements of firefox such as scroll bars and tabs but not on the minimise or close buttons in the top bar.

Also, the super key no longer brings up the app switcher in gnome or kde.

I've tried various things to diagnose the problem but I'm not making any progress. It doesn't seem to be a mouse/ hardware problem as I've used xinput --test-xi2 --root and I can see that every mouse click is being registered. I've tried moving the mouse to different USB ports but that has no effect. I've tried switching to a tty and back but still doesn't come back to normal. And I've tried many different desktop environments and it seems to happen in all of the ones I've tried (gnome, kde plasma, cinnamon). The only thing that restores normal mouse interaction with the desktop and windows is a reboot, which doesn't really count as a solution if you can't switching to something, save it and close it before pressing the power-off button.

I first noticed this happening in fedora 33 but thought the update to 34 would resolve it - it didn't, it may even be worse. I'm not sure how to solve this but it's happening almost every day now and I'm about ready to give up and go back to windows.... help...

6
  • 2
    Whatever you do, don't switch back to Windows. And what do your logs say?
    – john doe
    May 20 at 14:16
  • Have you tried another mouse? May 20 at 14:30
  • Is there anything unusual in journalctl/dmesg? Have you checked /var/log/Xorg.0.log and DM.log (i.e. lxdm.log, sddm.log, etc.) May 20 at 16:47
  • I couldn't agree more with john doe: don't go back to Windows. This could very well be a hw issue. What's the output of journalctl -xe? If you have another mouse laying around, can you plug it in and test if the issue persists?
    – telometto
    May 20 at 18:22
  • @EduardoTrápani I've tried a different wireless mouse and it still happens, but it was also a logitech, as opposed to my normal MX Master 2. Maybe it could be a logitech issue but I'd be surprised as I used with this machine since Fedora 31. I may need to check with a wired mouse to clarify.
    – jpmorr
    May 20 at 19:05
0

It appears after much testing this problems lies with the use of a logitech mouse, an MX Master 2 in my case. Replacing the logitech with some random wired mouse seems to have completely resolved this issue. It seems the lack of official Linux drivers can cause serious problems when using the MX2. There are some projects (piper, solaar) that try to bring support to Linux but I haven't tested any of these yet, so unsure how reliable they are or wheter they would resolve my problem.

Seems I just need to buy a good wired, Linux supported mouse. Recommendations welcome!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.