3

I am running an ubuntu 20.04 docker container on macos in order to use Dell racadm.

If I run the container normally (docker run -ti my:container racadm -r [IP] -u user -p pass getsysinfo) I get the following error:

ERROR: Unable to connect to RAC at specified IP address.

However it does work if I change the default network mode to host (docker run -ti --network host my:container racadm -r [IP] -u user -p pass getsysinfo). At first I thought maybe the container just had no route to [IP] especially since I am using a corporate vpn to connect to that network, but I can ping/traceroute/telnet to open ports on that IP in either network mode.

Note: this issue only started happening after I recently rebuilt my macbook (reinstalled OS), prior to that racadm worked fine in bridge (the default) network mode from the same container.

What should I look at to troubleshoot this issue? Does racadm create a new connection back to my machine that may be getting hung up by some nat/firewall rule?

0

1 Answer 1

3

So I know this is a little older but hopefully this may help you or someone else with a similar issue.

My issue was connecting to a iDRAC6 from a CentOS8 host gave me the same error, but it worked from a CentOS7 host without a problem. I installed the same iDRAC tools onto both CentOS hosts. I also had to install a prerequisite of openssl.

Turns out the issue was they both were using a different TLS version. The CentOS7 was using TLS v1.0, while the CentOS was using TLS v1.1. iDRAC6 doesn't let you change what version of TLS it uses. Basically I had to run this command update-crypto-policies --set LEGACY in order to tell the CentOS8 to use the legacy version of TLS.

This was the CentOS command, so not sure of the exact Ubuntu version if different, but hopefully this helps you or someone with a similar problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .