1

I have an Arch Linux setup running BSPWM, I don't use a login manager, but instead just run startx (with xinit). When I exit BSPWM and go back to the tty, I see the following error:

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)

I have an NVIDIA GPU (RTX 2070 Super) and have installed the (latest) proprietary drivers.

I'm not sure what is relevant to the issue, but I'll gladly include more info.

I did find this question, I didn't try the solution because frankly I'm not entirely sure what the impact of this would be (it's not really explained).

EDIT

I ended up trying the linked suggestion and it didn't work.

5
  • 1
    The answer suggests setting the SUID bit on the xinit executable. If that is the solution, then it should also work if you just run it as root. So try that first: log in as root and try startx. Do you get the same error? Also, are you sure it is an actual problem? Does everything work?
    – terdon
    May 17, 2021 at 17:17
  • I did try that, however I didn't configure root to start bspwm, sorry I'm somewhat of a noob. Anyway, I did try the linked suggestion and the issue persists. I'm not sure what the original permissions of xinitwould be, now that I see it didn't work. What chmod should I run to restore the original, would you happen to know that? May 17, 2021 at 17:25
  • 1
    Just the inverse command in this case: sudo chmod u-s /usr/bin/xinit. Please also answer my other question: is this actually a problem? Is anything not working? Do you have any reason to think this is more than a simple debug message?
    – terdon
    May 17, 2021 at 17:35
  • @terdon Everything seems to be working just fine, I "assumed" it's an error. I scoured the web looking for a solution. Btw, thank you so much for your help! May 17, 2021 at 17:37
  • 1
    You're very welcome. I am just thinking that X tends to be very verbose, so if it isn't causing you problems, I would guess you can safely ignore it.
    – terdon
    May 17, 2021 at 18:04

0

You must log in to answer this question.

Browse other questions tagged .