0

Being aware of that this is partially a known issue, since each is individual and different, the problem is as following:

On my Lenovo Laptop with Linux Mint the backlight cannot be set using Fn+F6/F7. These keys are not detected at all, neither by xev nor by acpi_listen. However other key combinations like Fn+F3 for volume up is detected by both commands. So it is a more low-level issue, I am afraid. On the other hand, this works well:

  • echo 10000 | sudo tee /sys/class/backlight/intel_backlight/brightness and as well
  • with the GUI slider in mate-power-preferences works perfectly.
  • xdotool key 232 or xdotool key XF86MonBrightnessDown

More detailed:

  • I tried many boot combinations (yes I updated GRUB and did reboot, as described in this troubleshooting wiki.ubuntu.com Debugging/Backlight)
  • I tried adding files in /usr/share/X11/xorg.conf.d/ as recommended (80-backlight.conf using both "Backlight" "ideapad" and "intel_backlight", or 20-intel.conf)

uname -a yields: Linux Lenovo-V14-G2-ITL 5.8.0-53-generic #60~20.04.1-Ubuntu SMP Thu May 6 09:52:46 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

These are the available backlights (which can be written using cat)

$ ls /sys/class/backlight/
ideapad  intel_backlight

This is my current configuration

$ cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-5.8.0-53-generic root=/dev/mapper/vgmint-root ro pcie_aspm=force acpi_osi=Linux acpi_backlight=vendor quiet splash

I tried these (as well individually and with many combinations, only visible effect is that the output of ls /sys/class/backlight/ is changing)

GRUB_CMDLINE_LINUX="pcie_aspm=force acpi_osi=linux acpi_backlight=vendor video.use_native_backlight=1"
3
  • Not sure, but if xev doesn't register your keypresses, I don't think there's much you can do. I guess you have two options: 1) Figuring out why xev does not register these keys; or 2) use different keys to bind a command (I had best experiences with xbacklight).
    – pfnuesel
    May 15 at 18:09
  • xev not registering keypress might be more common than I thought, see e.g. here: unix.stackexchange.com/a/584299/58056
    – pfnuesel
    May 15 at 18:11
  • The behaviour is similar to this askubuntu.com/questions/830948/… however I am stuck at the transition to the step where xev detects the keys . xdotool key 232 works well! And xmodmap -pke shows the brightness keys but how do I get the scancodes? With getkeycodes I see that there is not an entry for keycode=232 (so there is no scancode associated with it?)
    – camel
    May 15 at 19:07
0

Sorry, but I cannot leave comments so I have to use answer. What Lenovo model is it?

See if this works (and, as always, make a backup of any configuration file before modifying it):

  1. echo options hid_apple fnmode=0 | sudo tee -a /etc/modprobe.d/hid_apple.conf
  2. sudo update-initramfs -u
  3. Reboot

EDIT: If fnmode=0 doesn't work, you can try fnmode=2.

2
  • It's a Lenovo machine, probably a V14 G2-ITL as the hostname suggests. Why do you think options for an Apple keyboard would work here?
    – Freddy
    May 15 at 19:16
  • I have had the same problem with a layered keyboard (none of the my products are Apple, either) where some of the buttons didn't work when I pressed Fn. Changing the conf file and updating the initramfs (and rebooting) worked for me. Thought it might be worth a shot for you as well. Cheers.
    – telometto
    May 15 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.