1

I have being having issues with connecting to my wireless network at home, my system detect and sees the hotspot connection but when i want to connect it shows connection failed. Here is a list of things i have tried

  1. ping localhost {to make sure it is not a hardware problem}
  2. sudo lshw -C network {my wifi card shows here and the systems detects it}
  3. lsmod {and it shows my wifi module loaded}

I am a distro hopper so the issue started from when i was using linux-mint, i moved to pop-os, fedora-34, garuda-linux, ubuntu and finally in manjaro, but same issue.

This is the output of lspci

Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

This is the output of sudo lshw -C network

  *-network                 
   description: Wireless interface
   product: Centrino Wireless-N 1000 [Condor Peak]
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: wlo1
   version: 00
   serial: 8e:0d:ab:6a:10:0f
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=5.10.32-1-MANJARO firmware=39.31.5.1 build 35138 1000-5.uc latency=0 link=no multicast=yes wireless=IEEE 802.11
   resources: irq:29 memory:d3000000-d3001fff

I don't know if there is any thing else I should provide

5
  • 1
    I had your problem with a RTL8192EU, until both an updated driver and firmware were added to the system. I suggest you add to your question the model of your wifi adapter, and also check the logs at the time of connection. There's bound to be useful information there. May 13 at 15:45
  • 1
    Has anything else changed? A driver update? A firmware update in your router? (I am presuming by "my WiFi" you mean your wireless network a home... and not one of the many other meanings that would also be semantically correct)
    – C. M.
    May 14 at 1:16
  • @EduardoTrápani i have added the model and some information
    – Chigbata
    May 14 at 5:35
  • @C.M. yes i mean my wireless network at home, more precisely my smartphone hostspot connection, though i tried connecting to some public wifi and still same thing
    – Chigbata
    May 14 at 5:37
  • 1
    Okay, I am presuming you checked the obvious (like correct access method and password, etc). What is the contents of your /etc/network/interfaces file and any files in the /etc/network/interfaces.d directory? Do you have a /etc/NetworkManager directory (Note the ProperCase for this). What is the output of both ifconfig and iwconfig? Give us a clearer idea of how you are set up and configured so we can help... And edit your original question so others can see it right away without having to sort out these comments.
    – C. M.
    May 14 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.