1

I have, and able to boot with arch Linux with kernel 5.10.34 normally. I have older Linux (linuxmint 20.1) on my sda6 with kernel 5.4.0-72 and 5.8.0-50. I am using grub-customizer. Kindly not answer with having live cd.

The strange thing is:

  • when I tried to boot to my sda6 is, the /etc/fstab empty.
  • it stuck at busybox(initramfs) with, /init exist.
  • the exiting from the initramfs resulting kernel panic not sync.
run init: can't execute '': no such directory
kernel panic - not syncing: Attempted to kill init!
CPU 0 PID 1 Comm run-init Not Tainted 5.8.0-50 generic # 56~20.04.1-Ubuntu
call trace omitted: assuming just the panic that significant
  • last time I use the Linux mint, I open a terminal with sudo on /var/www/somedir/, strangely the kernel was misplaced there.

what i have tried:

  • using ridinit=/bin/sh (i missing the unix.stack q)
  • manually copy /etc/fstab from arch to /etc/fstab busybox
  • disable the selinux

the old fstab before installing arch Linux (Manjaro).

detail about the busybox BusyBox v1.30.1 Ubuntu 1:1.30.1-4ubuntu6.3

/sda1/boot/grub/grub.cfg

having said that, my question is how to create a permanent grub config so I am able to boot to my linuxmint properly?

Amend

blkid

lsblik

executing ash init from initramfs resulting:

enter image description here cat init: result of cat /init: /init Thank you

10
  • Have you tried to regenerate the grub config in Arch, i.e. install os-prober, mount /dev/sda6 and run grub-mkconfig -o /boot/grub/grub.cfg?
    – Freddy
    Commented May 8, 2021 at 19:34
  • I forgot to mention on the question, I assume the os-prober is included on grub-customizer. Commented May 8, 2021 at 19:41
  • Hi, thou hast summoned me. ;) Could you run lsblk and blkid and tell me which are your mint partitions (boot and root)? And your current grub.cfg? Also, did you run grub-mkconfig?
    – rudib
    Commented May 10, 2021 at 18:19
  • it's the dev/sda6, I will update the q, no i just using the grub-customizer. Commented May 10, 2021 at 18:38
  • Thanks, but could you still run sudo grub-mkconfig. It wont change your configuration, it'll (try to) detect all available OS's and just write the config to stdout. Then we can compare it to your current grub.cfg
    – rudib
    Commented May 10, 2021 at 18:48

1 Answer 1

0

Yet, the whole partition on my sda6 is kinda repositioned, sorry for the lack of a better term. My long desperation is paid because, no actual data loss. Just all the important file (the /) is moved to cwd when I am doing upgrade as long as I remember it.

enter image description here

I hope this q can stay open, expecting some insight from the community. Even the main trigger of this kind of failure is unclear. I tried copying / from a live cd it won't make the partition bootable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .