0

I'm new to Linux, I installed Mint 20.1.

The thing is that while trying to use some code using numpy I get this error:

enter image description here

I tried updating python and now it seems I have two versions of it.

If in terminal I type python3 I get this message

enter image description here

If I type python3.9 i see this

enter image description here

Maybe is because of this? I really appreciate your help, thanks!

4
  • 2
    You need to install numpy for the version of Python that you are using and make sure that it is prepended to your PATH.. Commented May 8, 2021 at 20:39
  • 1
    Please don't post images of text. Also, be aware that Pyhon2 and Python3 are installed in to their own separate places within your system for a reason--they are not cross-compatible. Install the version of numpy targeting the version of python you want to use (or install both, since they install to different locations and will not conflict).
    – C. M.
    Commented May 11, 2021 at 21:46
  • @C.M. ok! i'll have that in mnind for future questions Commented May 13, 2021 at 12:43
  • @NasirRiley i finally changed interpreter path in vs code and now i can run the code correclty, thanks! Commented May 13, 2021 at 12:44

1 Answer 1

0

I finally changed interpreter path in vs code and now i can run the code correctly,

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .