6
~$ dmesg | tail
[  479.558062] usb 1-1: SerialNumber: S07F1601A00000090095
[  479.559231] scsi7 : usb-storage 1-1:1.0
[  480.557093] scsi 7:0:0:0: Direct-Access     Ext Hard  Disk                 PQ: 0 ANSI: 4
[  480.558308] sd 7:0:0:0: Attached scsi generic sg1 type 0
[  480.559916] sd 7:0:0:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
[  480.560421] sd 7:0:0:0: [sdb] Write Protect is off
[  480.560426] sd 7:0:0:0: [sdb] Mode Sense: 10 00 00 00
[  480.560793] sd 7:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[  480.573472]  sdb: sdb1
[  480.575421] sd 7:0:0:0: [sdb] Attached SCSI disk

If i click on the HDD in nautilus I get this error:

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

Any help?

  • Mind that I dont want it to be mounted on boot. It should be automounted if plugged in. But I switched back to Ubuntu 12.04. Debian is not made for Netbooks. – ManuelSchneid3r Feb 16 '13 at 16:57
  • I beg to differ. Debian works perfectly with my Dell Mini netbook. To be fair, though, I'm talking about squeeze not wheezy. – Joseph R. Apr 30 '13 at 13:18
10

This is Debian Bug #631504 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631504).

As is also mentioned there, the entry in fstab for /media/usb0 should not be there. It prevents Gnome from mounting the USB drive automatically and with the right permissions. This line (or lines, I had two of them, one for /media/usb0 and one for /media/usb1) should be commented out. This worked for me. I am not sure where this line is coming from in a fresh Wheezy install, a posting in the bug report mentioned above presumes that it might have something to do with installing Wheezy from an USB-stick.

  • 1
    +1 Worked for me. And yes it seems it's related to installing from USB stick as my current Wheezy setup was installed this way. – Joseph R. Sep 30 '13 at 19:15
  • I also had the same problem, and I too had installed from a USB stick. Thanks for the solution! – sashoalm Jan 3 '14 at 22:17
0

You need to add your user to the appropriate group , then relogin. That group being disk, if memory serves.

  • sudo adduser manuel disk did not solve the problem. I am in these groups: disk cdrom floppy sudo audio dip video plugdev scanner bluetooth netdev – ManuelSchneid3r Feb 15 '13 at 12:30
  • If you start nautilus as root, it works, right? BTW, you said "doesn't work anymore". What changed? An update? – schaiba Feb 15 '13 at 12:33
  • Yesas root it works according th fstab entry /dev/sdb1 /media/usb0 auto rw,user,noauto 0 0. I was wrong it did never work. – ManuelSchneid3r Feb 15 '13 at 13:17
0
  1. Try another USB port. Or do you have another OS ?
  2. If your OS won't mount your USB drive, you can mount it yourself.
  3. Plug in the USB pen.

In terminal type: # fdisk -l (so that you will see the device such as: /dev/sda1) Mount it: # mount /dev/sda1 /mnt/temp (you have to make sure /mnt/temp exists)

You shall have to be root to run the above commands. Good luck.

0

Installing ntfs-config and setting read/write permissions solved this for me.

-1

Simple: ntfsfix /dev/partition

Not the answer you're looking for? Browse other questions tagged or ask your own question.