4

Thunderbird pats itself on the back for not loading external content and protecting your privacy, but at the same time has a bright yellow notification bar tempting you constantly to do exactly that:

enter image description here

There is a description of how to make that notification bar go away in Windows here. They want you to create a file called userChrome.css and add the following to it:

#mail-notification-top{
display: none;
} 

I'm using Thunderbird 78 and Debian 10 and did a find search in my user folder and found .themes/CBlue/cinnamon/userChrome.css and added that css to it, saved and rebooted, but the notification in thunderbird is still there. Any ideas how to make it go away?

5
  • You could at the very least translate the german line. May 7, 2021 at 11:40
  • 1
    Why? The point is well made May 7, 2021 at 12:55
  • Cardamom, you've edited the CSS for Cinnamon. Probably worth reverting that change May 7, 2021 at 12:55
  • 1
    To protect your privacy, Thunderbird has blocked remote content in this message is the message they have in the English version. @roaima thanks, have changed Cinnamon back.
    – cardamom
    May 7, 2021 at 18:52
  • It would be nice to have a button instead of a banner warning about the remote content. A lot of email has remote content (images, tracker pixels, etc), so I constantly end up seeing that yellow banner on every email. 10 hours ago

1 Answer 1

4

In Linux, userChrome.css needs to be created in ~/.thunderbird/blahblah.default/chrome, where blahblah.default is replaced with the name of your actual profile folder in ~/.thunderbird.

Just tried it on my install, and it works as expected.

5
  • Thanks, have voted up, are you on Thunderbird 78? Is that the only thing in your userChrome.css or is there some kind of namespace thing? This is now turning into a real pain.. There seems to be more to it, like the css no longer loads automatically, at the bottom of this page there is an answer which says that in Thunderbird 78 you need to tell it somehow to load userChrome.css ! I just spent about half an hour trying.. Some other links about this - 1
    – cardamom
    May 7, 2021 at 19:29
  • 2, My exact version number is 78.10.0 Say if anyone knows how to make that css file load
    – cardamom
    May 7, 2021 at 19:34
  • I'm running 78.8.1 (64-bit). My original test was with a bunch of other stuff in the css file. I just tried userChrome.css empty except for your bit of css, and it worked as well. You probably did this, but just to make sure... Did you close TB and restart it after adding or changing userChrome.css? Because that's necessary for TB to apply the changes. May 7, 2021 at 19:58
  • 1
    If that isn't it, this might be... Check TB's Config Editor for toolkit.legacyUserProfileCustomizations.stylesheets and set it to true if necessary (mine's set to true; switching it to false and restarting TB disables css). If you have to set it, you'll probably need to restart TB for the css to be applied. Suggested by this page about Firefox. May 7, 2021 at 20:14
  • 1
    That was it but you have to chnge toolkit.legacyUserProfileCustomizations.stylesheets in TB not in firefox. Thanks so much for testing these things! It looks beautiful now, that should be standard without that stupid yellow banner. That was quite convoluted to get rid of it.. Went to 'settings' (not 'folder settings' or 'account settings') and scrolled to the bottom, selected 'edit configuration' and accepted the warning.
    – cardamom
    May 8, 2021 at 2:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .