0

I'm new to using Linux and I tried googling an answer but I didn't understand the instructions. I installed Lubuntu but I must've messed up somewhere because my computer goes directly to GRUB.

After pressing tab and trying a bunch of commands, I was finally about to load the BIOS thing in order to have it boot USB first. For some reason, I can't boot the USB and nothing happens when I click F12 and choose SanDisk from the boot menu. The ISO is for CloudReady if that helps. I read online about booting from within GRUB but it tells me I have to do something with the kernel first. I think the file is startup.nsh since that's the only file I could find while checking each hd. It would be much appreciated if someone could help me with easy instructions since I've searched for hours and tried everything I could find but I didn't understand how to do it properly.

Sorry if I wasn't clear so I'll try to list what I did.

  • I have an old Gateway computer sx2110g with Windows 10 installed. Windows was slow so I wanted to try a version of Linux.
  • I tried installing Lubuntu but I must've messed up because my computer only boots in GRUB.
  • After looking online i found that typing fwsetup on Grub let's me restart into the BIOS.
  • I wanted to install a different OS so I set "removable device" to boot first.
  • When I restart it only says "boot loader not found" then immediately goes to Grub.
  • I tried f12 to manually choose the USB drive but the same thing happens and it immediately goes to Grub.

My question is that if there's a way to boot a USB from within Grub since that's the only thing that's opening for me on the computer. I tried these instructions: https://szymonkrajewski.pl/how-to-boot-system-from-usb-using-grub/ I was able to figure out which drive is the USB by typing "ls" and searching each drive but I don't know how to boot startup.nsh.

2
  • startup.nsh would be a start-up script for a UEFI shell. It should not have anything to do with booting Linux unless your set-up is very special. Please edit your question to add as much hard facts as you can: the make and model of your system, the exact messages you're seeing from GRUB, and URLs to instructions you have tried to follow so far. "It tells me I have to do something with the kernel first" sounds like one of the previous commands you've tried has failed, and you're trying to keep going regardless; that won't work.
    – telcoM
    May 7, 2021 at 6:26
  • have you tried booting the stick on a different computer? can you boot your computer with a lubuntu-stick? I am pretty sure that the problem is your cloudReady-Stick and not you bios/current installation
    – blaimi
    May 7, 2021 at 14:22

1 Answer 1

0

To boot UEFI-style from a removable device, that removable device should have a partition that is readable to the UEFI firmware (all UEFI systems will read FAT32, usually also ISO9660, some will read NTFS too) and the partition has \EFI\BOOT\BOOTX64.EFI. If such a file does not exist, then that partition is not bootable without additional configuration, as far as the UEFI firmware is concerned.

startup.nsh is not a bootloader. It is a start-up script file for EFI shell.

An EFI shell is sort of halfway in functionality between a Linux busybox shell and a Windows cmd.exe command prompt... but it can run on top of UEFI firmware: it does not need any OS kernel. It is usually named shell.efi but can be renamed to <anything>.efi, or can be an embedded feature in some UEFI firmware implementations.

startup.nsh can only run *.efi files, other *.nsh scripts and internal commands of the EFI shell.

I downloaded the home edition of CloudReady. It's available as a Windows .exe or a .zip file that contains a .bin disk image, so I don't know what you are talking about an ISO. But the disk image file has a hybrid MBR/GPT partition table: when interpreted as MBR it shows just two partitions, but interpreted as GPT, it has a whopping 27 partitions!

An old computer that clearly has UEFI (since GRUB's fwsetup works) might have an early version of UEFI firmware that may not have been tested with such complicated set-ups, and as a result, UEFI firmware bugs might prevent booting a CloudReady USB stick. Try with something simpler first.

In the GRUB prompt, type set and press Enter. It should output several lines of text. Are there lines that start with prefix= or root=? What do they say exactly? If there's so much text it scrolls off the screen, type set pager=1, press Enter, then set and Enter again. Now it should pause between screenfuls of text.

If any command results in an error message, please copy it exactly and edit the command and the error message into your question. You might not know what it means, but someone here will.

1
  • Thank you all for your help. I was dumb and didn't know Cloudready was a bin instead of an ISO. I tried Lubuntu again and it installed fine. I really appreciate the help since I can finally use the computer again.
    – Jak
    May 7, 2021 at 22:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .