0

I'm trying to install arch on a Thinkpad T14 gen 2 and using ethernet to do it (the wifi card isn't showing up in ip link, iwctl device|adapter list, or iw dev despite showing up in rfkill and the driver showing having been loaded in lspci -k; but that's not the issue right now).

Pacman and reflector are behaving extremely strangely. I can curl almost anything, but reflector consistently fails on this machine by timing out, rankmirrors doesn't output anything and just hangs, and even using the full US list of mirrors generated by

curl 'https://archlinux.org/mirrorlist/?country=US&protocol=http&protocol=https&ip_version=4' > mirrorlist

I'm getting flaky downloads. Most small packages download no problem, a lot of the time bigger ones have trouble. Downloading linux-5.12.1.arch1-1-x86_64.pkg.tar.zst right now has failed at least 20 times with the statement "Operation too slow. Less than 1 byes/sec transferred the last 10 seconds." most failures at 0%, a couple at 1%, one at 6%, and one at 10%.

Pacman and reflector are working fine on my desktop machine, also wired, through the same switch and router.

What I find strangest is that a package can download from a mirror, and then another package fail from the same mirror. As I said, 25+ failures on downloading linux right now.

What can I do to debug this? Is this likely to be my machine, something wrong with the connection to the router, or is there something I'm not seeing?

Update: I tried curling the iso and the estimation was 40 hours and it died. I also cancelled the download and rebooted back into windows (I'm installing dual boot) and tried downloading the iso and it worked fine. I just rebooted the router, and I found myself in an infinite loop during the iso boot sequence with Errors including "Reflector can't update list".

I'm beginning to think there's a problem with the flash disk. When I catted the arch iso to it earlier it took forever. I tried switching to another disk and it took maybe a minute.

It seems that that was ultimately the issue.

1 Answer 1

0

The solution was to find another installation media. Something was corrupted with the flash drive. Crazy how these sorts of things can present themselves.

2
  • Since it's self answered, kindly specify which part of arch is corrupted. Then mark your own answer May 10, 2021 at 20:35
  • It wasn't Arch that was corrupted, it was the flash drive itself. The flash drive is "broken".
    – mas
    May 13, 2021 at 22:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .