0

I am trying to install a fluid simulation software (https://github.com/cwrowley/ibpm). I have installed all the dependencies and was ready to execute the make command. Here is the error that I am getting from terminal.

(base) hell@hell-Precision-T1600:~/Desktop/temp/von_karman/ibpm-master/ibpm$ make
cd build && make
make[1]: Entering directory '/home/hell/Desktop/temp/von_karman/ibpm-master/ibpm/build'
../config/make.inc:1: *** missing separator. Stop.
make[1]: Leaving directory '/home/hell/Desktop/temp/von_karman/ibpm-master/ibpm/build'
make: *** [Makefile:15: ibpm] Error 2

I also checked the Makefile in the parent directory. Here are the contents of the Makefile.

# Main makefile for IBPM code
#
# Clancy Rowley
# Princeton University
#
# $Date$
# $Revision$
# $Author$
# $HeadURL$

.PHONY: ibpm test doc clean distclean
DIRS = build test doc

ibpm:
    cd build && $(MAKE)

test:
    cd test && $(MAKE)

doc:
    cd doc && $(MAKE)

all: ibpm test doc

clean:
    for dir in $(DIRS); do ( cd $$dir && $(MAKE) clean; ) done

distclean: clean
    for dir in $(DIRS); do \
      ( cd $$dir && $(MAKE) distclean; )\
    done

I don't know which missing separator it is talking about.

The file make.inc links make.inc.gcc. Here are the contents make.inc.gcc.

# standard config file, using gcc compiler

CXX = g++

# flags for compiling with optimization
CXXFLAGS = -Wall -g -Ofast -funroll-loops -DNDEBUG

# for debugging, uncomment the following line
# CXXFLAGS = -Wall -g

# Specify directories for libraries and header files here
# lib_dirs = -L/path/to/lib

# include_dirs = -I/path/to/include

Also, when I execute cat -A config/make.inc, I get make.inc.gcc

8
  • 1
    Can't reproduce - the first line of config/make.inc (whichever ordinary file it links to) should be a comment - did you edit the file and remove the comment character # by any chance? May 4, 2021 at 13:45
  • @Prakhar Sharma → cd ibpm/ && make : No errors. ( g++ version 10.3.0 ) ... ibpm depends on libfftw3. May 4, 2021 at 14:02
  • @KnudLarsen I have all dependencies installed. My g++ version is 9.3.0. I can't get new version even after running sudo apt get update. May 4, 2021 at 18:14
  • @steeldriver I have changed anything. Also the first line of make.inc links the make.inc.gcc. Here are the contents of the file. # standard config file, using gcc compiler CXX = g++ # flags for compiling with optimization CXXFLAGS = -Wall -g -Ofast -funroll-loops -DNDEBUG # for debugging, uncomment the following line # CXXFLAGS = -Wall -g # Specify directories for libraries and header files here # lib_dirs = -L/path/to/lib # include_dirs = -I/path/to/include May 4, 2021 at 18:18
  • Please edit your question with this information - in fact, please add the output of cat -A config/make.inc May 4, 2021 at 18:32

1 Answer 1

1

The solution suggested by steeldriver actually worked. There is an error in the make.inc file. The make command should work once the file make.inc.gcc is linked to make.inc using the command ln -sf make.inc.gcc config/make.inc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .