0

I recently did a fresh install of Pop!_os after getting a little brave and wrecking some stuff on accident. I dual boot Windows 10 and Pop on separate drives. Upon restart, GRUB loads into its grub> prompt instead of my boot menu, and I have to use a series of commands to get it to load into the bootloader menu:

grub> set prefix=(hd1,gpt3)/boot/grub
grub> set root=(hd1,gpt3)
grub> insmod linux
grub> insmod normal
grub> normal

This will throw me into my bootloader menu without a problem, but the change does not persist on the next boot. I do a sudo update-grub every time I get into Pop, to no avail. I'm wondering if there is a config file I can edit or something in order to make these changes persistent, as I'm not a fan of having to issue these commands every time I want to get to my grub menu. The worst part is, I had this exact issue on my previous install, and it annoyed me for weeks, until I eventually got it to work. I cannot remember what I changed for the life of me. I'm not very familiar with the more involved workings of Linux like boot and all that, so I apologize if this is a very obvious stupid question. Thank you!

3
  • the sudo update-grub is just to update grub menu. You may need to reinstall grub. If you can boot into install, you just need sudo grub-install /dev/sdX where sdX is your Linux drive. If hd1, it may be sdb? or second NVMe drive? It should know if BIOS or UEFI based on grub you have installed and reinstall correct grub. Otherwise: Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed. help.ubuntu.com/community/Boot-Repair
    – oldfred
    May 3, 2021 at 2:41
  • @oldfred Heyo, here is my Boot-info: paste2.org/VvPcKU3H I'm now realizing my drive setup is a little wacky. The 1TB and 2TB drives are /home for Linux and file storage on Windows, sda is a games SSD, sdb is my Windows install, and sdc is my Linux install. These mounts do not correspond exactly with what comes up when I ls at the grub prompt, however.
    – Tanner
    May 3, 2021 at 11:17
  • You only show sdd as MBR, so system is using gpt. Windows only boots using UEFI from gpt drives, so Windows must be UEFI. But you show various BIOS/MBR boot loaders in gpt's protective MBR. Old Windows boot loaders will not work, grub can work in BIOS mode from gpt, but better to only use UEFI. You show sdc1 as ESP for both Windows & POP. And sdd1 on old MBR drive as /home. If booting in BIOS mode to old grub in MBR, you will get the grub> prompt. Just change boot to UEFI mode in UEFI settings. Plan on eventually converting sdd to gpt, but that will change UUID & may lose all data.
    – oldfred
    May 3, 2021 at 14:07

1 Answer 1

0

I managed to fix my issue by running boot-repair with the "Purge GRUB" setting checked, and the "Secure Boot" setting unchecked. I never thought to check out the advanced settings, which is my fault. Thank y'all for giving me a hand!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.