2

I have a 60 Hz monitor, but Gnome 40 settings only allows 49.99 Hz (and 29.99 Hz). I'm running Wayland, obviously. Gnome monitor settings with the refresh rate dropdown open, showing options 49,99 Hz and 29,99 Hz

Why is that?

Gnome's animations don't feel smooth either, can that be related?

It's quite a big monitor with 3440 × 1440 px², and in another older question How to force 60 Hz in 1366x768 despite kernel bug after kernel 4.13? it states that there's a kernel bug that limits refresh rate on high resolutions due to power savings with Xorg. Might this still be relevant and related?

I'm on a Lenovo T470s with Intel Corporation HD Graphics 620 (rev 02).

4
  • What does the EDID tell ?
    – MC68020
    Nov 5, 2022 at 10:00
  • Thanks for the suggestion. It says # Monitor preferred modeline (60.0 Hz vsync, 66.7 kHz hsync, ratio 16/9, 157 dpi). The ModeLine seems rubbish, it’s set to FullHD. Also, the screen size in cm and inch is totally off. Also, the screen is 21:9, not 16:9. But this does not concern refresh rate.
    – Andy
    Nov 5, 2022 at 10:13
  • So you mean the EDID is just broken. What does the Xorg.log tell when setting the display ?
    – MC68020
    Nov 5, 2022 at 10:40
  • I’m on Wayland. I believe there is no Xorg involved for quite a while now, is it?
    – Andy
    Nov 5, 2022 at 10:42

1 Answer 1

0

It turns out that the Intel HD Graphics 620 on a Intel Core i7-7600U supports 4K only at 24 Hz via HDMI, and respectively the 3440 × 1440 px² at 50 Hz.

The specification mentions 4K at 60 Hz via Display Port, and if I understand correctly, the DP interface is the USB-C plug.

When connecting the same monitor on USB Type-C port (DisplayPort), with a HDMI adapter, 60 Hz are the default and available in the dropdown.

It’s quite counter-intuitive that there would be a difference.

Animations seem way smoother now on USB-C.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .