0

This is similar to the question about http not supported, but I was not able to apply the solutions suggested there to my situation.

I've done

zypper addrepo https://download.opensuse.org/repositories/devel:tools:scm/SLE_12_SP5/devel:tools:scm.repo
zypper refresh

and I'm getting

Retrieving repository 'Software configuration management (SLE_12_SP5)' met
Download (curl) error for 'https://download.opensuse.org/repositories/devels:/scm/SLE_12_SP5/repodata/8ff6d5e77f953a771c9870113c655dfef8cf31ffba709feec8e0a617fc-primary.xml.gz':
Error code:  Bad URL
Error message: Redirect to protocol "http" not supported or disabled in li

Now if I

curl https://download.opensuse.org/repositories/devel:/tools:/scm/SLE_12_SP5/repodata/8ff6d5e77f953a771c9870113c655dfef8cf31ffba709f2506cceec8e0a617fc-primary.xml.gz

I see

<p>The document has moved <a href="http://downloadcontent.opensuse.org/repositories/devel:/tools:/scm/SLE_12_SP5/repodata/8ff6d5e77f953a771c9870113c655dfef8cf31ffba709f2506cceec8e0a617fc-primary.xml.gz">here</a>.</p>

But if I try to apply the solution suggested in the related question with a

vi /etc/zypp/repos.d/devel_tools_scm.repo

and I change https in http, then it does not work because the http URL does (no longer?) exist: http://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/devel:languages:php.repo

What am I doing wrong or what am I supposed to do to install git so?

1
  • 1
    Before you did all of that, did zypper install git not work? Apr 30, 2021 at 9:57

1 Answer 1

1

As you've indicated that what I mentioned in my comment worked after you tried it, I'm going to post it as an answer:

zypper install git

git is available in the SLES repos as it is in the repos for nearly every other distribution. In the case of SLES, the above command will install it as long as the repos are enabled.

2
  • Btw what if I need to install a version of something that is not available from zypper? I see that there is zypper install python36 but I would prefer python 3.9 on my SLES 12.5 : is it not doable? Thank you again
    – Giulio
    Apr 30, 2021 at 14:44
  • 1
    There are repos that you can add that have it but the best way is to build it from source and add it to your environment to avoid conflicts. Apr 30, 2021 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.