2

I like the way Xfce works on top of Linux Mint 14 Nadia (Quantal) - but I also like LXDE that I want to have in parallel. Mint 14 has no LXDE "version" now, and that is too bad.

I heard that installing multiple DE is not a problem. But ... problems may occur.

After installing LXDE (and I am not sure this is the real cause of that), when I log in Xfce (which is the main "flavour" of my Linux Mint installation) all windows are missing the upper frame and buttons, and are stuck to the upper border of the screen. Alt-Tab would not work.

Reinstalling Xfwm4 didn't help.

LXDE behaves just fine - the Xfce session is useless. But all was perfect in Xfce until I installed LXDE and made 2 or 3 logout/login between the two DEs.

Before doing something radical like reinstalling the system - any ideas?

1

The cause of this may be in a way related to LXDE but not directly: it is the Xfce's session manager that seems to be the real problem, and switching between different DE sessions might have triggered this. For some reason xfwm4 does not start or does not work properly at the start of an Xfce session. Browsing the internet I found that for this and other issues people recommend clearing session cache and setting not to save automatically the session at logout (source here).

So, in Menu/Settings/Session and Startup:

  • under Session tab:"Clear saved sessions"
  • under General tab: uncheck "Automatically save session on logout"
1

I had that problem and it was the Greybird theme messing up. Try a different theme. I'm using Default 4.6.

  • i use default too. when lately a similar problem reappeared (seemingly without any relation to LXDE) I added xfwm4 to the list of starting programs – user32012 May 26 '13 at 11:55
0

Try to reconfigure the package instead of making it start yourself:

sudo dpkg-reconfigure xfwm4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy