0

My computer is under Debian 10 with this Linux image :

uname -r
4.19.0-16-amd64

and a R8125 Ethernet card.

lspci | egrep -i --color 'network|ethernet'
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. Device 8125 (rev 05)
05:00.0 Network controller: Intel Corporation Device 2723 (rev 1a)

Today, a new Linux image, 4.19.0.17-amd64 appeared through apt-get update and apt-get dist-upgrade.
These done and the computer rebooted, it doesn't recognize the Ethernet card anymore, and an ifconfig respond : no peripheral found.
So, of course, I'm using the 4.19.0.16 boot to write this question...

Once, the reseller of my computer moaned about the installation he has had to do with a

make install

done from a driver directory, /opt/r8125 it appears he has downloaded from https://github.com/tmacro/r8125.

But I didn't really understood what he did.
I've attempted to use his trick, two months ago, on another Debian partition my computer have (with an image 4.19.0-16-amd64), but :

  1. it seems it didn't worked,
ls -l
-rw-r--r-- 1 root root 2511888 avril 24 13:43 r8125.ko
samedi 24 avril 2021, 13:43:55 (UTC+0200)
make -C src/ clean
make[1] : on entre dans le répertoire « /opt/r8125/src »
make -C /lib/modules/4.19.0-16-amd64/build M=/opt/r8125/src clean
make[2] : on entre dans le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
make[2] : on quitte le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
make[1] : on quitte le répertoire « /opt/r8125/src »
make -C src/ modules
make[1] : on entre dans le répertoire « /opt/r8125/src »
make -C /lib/modules/4.19.0-16-amd64/build M=/opt/r8125/src modules
make[2] : on entre dans le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
  CC [M]  /opt/r8125/src/r8125_n.o
  CC [M]  /opt/r8125/src/rtl_eeprom.o
  CC [M]  /opt/r8125/src/rtltool.o
  LD [M]  /opt/r8125/src/r8125.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /opt/r8125/src/r8125.mod.o
  LD [M]  /opt/r8125/src/r8125.ko
make[2] : on quitte le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
make[1] : on quitte le répertoire « /opt/r8125/src »
make -C src/ install
make[1] : on entre dans le répertoire « /opt/r8125/src »
make -C /lib/modules/4.19.0-16-amd64/build M=/opt/r8125/src INSTALL_MOD_DIR=kernel/drivers/net/ethernet/realtek modules_install
make[2] : on entre dans le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
  INSTALL /opt/r8125/src/r8125.ko
  DEPMOD  4.19.0-16-amd64
make[2] : on quitte le répertoire « /usr/src/linux-headers-4.19.0-16-amd64 »
make[1] : on quitte le répertoire « /opt/r8125/src »
  1. or I haven't done something else that was necessary.

It looks strange to me that the network driver isn't able to follow Linux upgrades, and it's boring, but I have to comply with this event.

I don't want to upgrade my Linux image up to a 5.10 image, but to stay using the current one Debian 10 suggests.

0

2 Answers 2

2

The RTL8125B support came with kernel 5.9. Debian 10 is using 4.19 in the stable channel.

You can update your kernel to 5.10 from debian-backports if that's ok for you like described e.g. here.

This is a very common problem with current distributions and this controller. The controller is used by many manufacturers on current boards with AMD-Sockets.

I hope that helps, I had to buy a USB-Ethernet-Adapter because when I bougth my board, 5.9 was not yet released by mainline :/

EDIT: To install the new kernel without Internet, you can download the following packages, transfer them via a usb-stick and install them with the command sudo dpkg -i *.deb && apt install -f and reboot. You should now be able to configure your network.

Another (maybe easier) way is to connect your mobile via usb and tether its WiFi/LTE-Connection for the kernel-update.

2
  • How is it? Could you update? :)
    – blaimi
    May 7, 2021 at 13:47
  • I've found currently no way to repair this defective legacy installation, and plan to leave it alone... But I didn't seen your update then. I will think about it. May 7, 2021 at 14:02
0

You know the story : you only have to post/edit your question, and a few minutes later, it works...

So I wrote here the only things I did but (this time) worked, to help who would stumble upon the same problem I've encountered:

  1. Go on the session where Ethernet connection is still available and download the Git project https://github.com/tmacro/r8125 (for me, reseller put it in /opt), or put its content on an USB key.

  2. Boot on the no-working session (here the 4.19.0.17-amd64 for me) and execute:

cd /opt/r8125/
sudo ./autorun.sh

The image 4.19.0.17-amd64 is updated and network works immediately.

(epilogue: I think I was misled by my reseller who told me to do a make install from /opt/r8125 directory when it was a ./autorun.sh that had to be done? Maybe...)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .