I'm accessing a samba share on a Windows Server 2019 from a PC with an updated Debian 10 buster OS with the command:

sudo mount -t cifs -o vers=3.11,username=myname,uid=1000,gid=1000 //the.server/some/share/ /home/myname/some/dir

On the top level I'm able to create and rename files without problems:

>> cd ~/some/dir
>> touch del.me
>> mv del.me del1.me

However, if I try to rename a file in a subdirectory, it doesn't work anymore:

>> cd ~/some/dir
>> mkdir subdir
>> cd subdir
>> touch del.me
>> ls -la
total 8
drwxr-xr-x 2 myname myname    0 Apr 27 11:56 .
drwxr-xr-x 2 myname myname 8192 Apr 27 11:56 ..
-rwxr-xr-x 1 myname myname    0 Apr 27 11:56 del.me
>> mv del.me del1.me    
mv: cannot move 'del.me' to 'del1.me': No such file or directory

Deleting the file created in the subdirectory with rm del.me works without problems.

What could be the reason? I've tried looking online for the problem but cannot find a solution. In other shares on the same server (//the.server/another/share/) mounted in the same way and with the same permissions, moving files works without problems. I've also tried accessing the share from a different PC (running a Debian testing OS), and the problem persists. My samba version is 4.9.5-Debian.

  • Can you cat del.me or ls -l del.me? Commented Apr 27, 2021 at 11:37
  • @roaima The ls -l is shown above. For the example shown, since I just "touched" it, del.me is empty, but I have the problem with files with content too. Running cat doesn't give any errors
    – Robe
    Commented Apr 27, 2021 at 11:45
  • I saw your ls -l, I'm curious to know about the ls -l del.me with an explicitly referenced file name Commented Apr 27, 2021 at 11:46
  • 1
    @roaima noperm doesn't work either. The login name is the same...
    – Robe
    Commented May 4, 2021 at 8:45
  • 1
    @roaima I fixed the problem specifying vers=1.0. I had already tried 3.11, 3.0 and 2.0 but had to go back even further. Thanks for the support!
    – Robe
    Commented May 10, 2021 at 8:57

2 Answers 2


The problem was fixed specifying version 1.0:

sudo mount -t cifs -o vers=1.0,username=myname,uid=1000,gid=1000 //the.server/some/share/ /home/myname/some/dir

The bug affects debian systems and is known since January 2021: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=949394


When I've seen this error even sudo rm del.me didn't work for me. Touching the "nonexistent" file and then rm-ing did.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .