0

I've had this issue throughout distros. Arch, Debian, Mint, etc. Tried gnome, kde, xfce. My brightness control buttons, Fn+Vol_Up / Fn+Vol_Down will not actually do anything. I still get a gui feedback on my screen showing the brightness meter changing but the brightness never really changes. Brightness works fine on ubuntu and windows.

Here's the workaround I used for months. I bind my volume keys with the command xbacklight -dec/inc x and it's whatever but gets the job done.

Other thing I can do is manually modify values of /something/somewhere/class/backlight/Intel_backlight/brightness and it takes effect immediately when I save the modified file.

But it's really concerning to me why it doesn't actually work the way it's intended to. I have asked this question multiple times on different forums but it never gets any response for whatever reason so if anybody can recommend me any place that might be helpful then please let me know.

Here's what I have found so far. Instead of amending the /somewhere/backlight/Intel_backlight/brightness file my shortcuts instead modify the /IDK/backlight/dell_backlight/brightness file.

I tried the method from arch wiki where I make a file in /etc/X11/xorg.conf.d/20-intel.conf but it does not work.

4
  • 1
    Just to clarify: the problem is not that you couldn't make it work by using keybinds and/or a script, but why it doesn't work out of the box?
    – FelixJN
    Apr 27, 2021 at 9:22
  • Well I am not sure. At the end if the day I can make it work. Correct me if I am wrong but I always thought those were workarounds. Like complete bypass of the way it actually is supposed to work. My keybinds are changing the backlight using a different program then what's originally supposed to make it change, right... But I guess you can put it like that. It's not working out of the box so where's the problem? Why aren't the default shortcuts or brightness sliders working?
    – user334374
    Apr 27, 2021 at 23:09
  • 1
    It working fine on Ubuntu and Windows while it fails on Arch and Debian could be a hint that it is connected to closed-source graphics drivers: Ubuntu uses proprietary drivers by default, where Debian by default does not. You could thus try adding e.g. the non-free repositories for Debian, get the closed-source driver and retry.
    – FelixJN
    Apr 28, 2021 at 8:02
  • I had installed all the necessary non-free drivers when I was on Debian, Currently on arch linux with kde. It still didn't work. Now it's really getting on my nerves. I've been thrashing the internet for a result this past 13 hours. I haven't slept and I can't figure out what's causing it. How is the brightness controlled to begin with? Reading the arch I can tell that pressing volume key directly modifies the file in */backlight/Intel_backlight/brightness but instead mine modifies the file in /something/dell_backlight/brightness. How do I make it modify the correct file?
    – user334374
    Apr 28, 2021 at 10:15

1 Answer 1

1

I added the following kernal parameter and updated the grub.

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=video"

The other options were not working for me which is what I had set in the grub after reading the arch. Replacing those with this fixed the issue.

Thank you felix for you help! :)

You must log in to answer this question.