1

I've been using ZFS without much troubles so far, but today I got a quite strange error. I was basically doing an incremental send (encrypted hard drive) with something like:

$ sudo zfs send -w -v -i  "#myoldsnap" "mylocalzfspool/encrypted_home@mynewsnap" | sudo zfs recv myexternalpool/backup/Laptop -F
send from mylocalzfspool/encrypted_home#myoldsnap to mylocalzfspool/encrypted_home@mynewsnap estimated size is 13.8G
total estimated size is 13.8G
cannot receive incremental stream: IV set guid missing. See errata 4 at https://openzfs.github.io/openzfs-docs/msg/ZFS-8000-ER.

But, if I replace #myoldsnap with @myoldsnap (i.e. if I use snapshots instead of bookmarks), then it works... However, I would prefer to use bookmarks since later on I may mant to remove snapshots to save space.

In case it helps, here is the proof that I do have my old snapshot on the external disk, and my bookmark on the local disk:

$ sudo zfs list -t snapshot -o name
NAME
mylocalzfspool/encrypted_home@myoldsnap
mylocalzfspool/encrypted_home@mynewsnap
[...]
myexternalpool/backup/Laptop@myoldsnap


$ sudo zfs list -t bookmark 
NAME                                                                                 USED  AVAIL     REFER  MOUNTPOINT
mylocalzfspool/encrypted_home#myoldsnap                            -      -         -  -
mylocalzfspool/encrypted_home#mynewsnap                                     -      -         -  -

Any idea why it failed on bookmark? Usually I don't have much issues, meanwhile I just created another volume on the external pool, and I tried once to open ZFS with an older version that was not supporting encryptions and I just got an error... but it's all I can think of.

1 Answer 1

0

I know this post is old but I had this problem today and wanted to add my findings.

It turned out that in my case sending the bookmark created a bad stream, this could be checked with zstreamdump on the source:

zfs send -w -i  "#oldsnap" "tank/home@newsnap" | zstreamdump | grep from_ivset_guid
        from_ivset_guid = 0x0

The snapshot, however, would create a proper "IV set guid" value:

zfs send -w -i  "@oldsnap" "tank/home@newsnap" | zstreamdump | grep from_ivset_guid
        from_ivset_guid = 0x968b62ce478cf1

The source Ubuntu was a bit older than the target so I tried apt upgrade and then zpool upgrade tank, neither of which improved the situation.

However, deleting and then recreating the bookmark with the system upgraded did resolve my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .