I am trying to create some mount points between two Debian 10 machines using NFS. On the server I have this information in my /etc/exports file:


Then on my client I have this in the /etc/fstab file: /mnt/nfs/home nfs4 defaults,user,exec,noauto 0 0 /mnt/nfs/var/nfs nfs4 defaults,user,exec,noauto 0 0

Both files have been saved. I have made sure that the firewall allows nfs. After typing the

mount -a 

command. It runs as if it was successful, but I do not see the mounts. I use "mount" or "df -h" to look for the mounts and there is nothing on the mounts I created. Not sure what else I am missing. Suggestions? Please

1 Answer 1


The noauto parameter you specified for your two filesystems instructs mount -a to ignore them!

Quoted from man mount :

mount -a [-t type] [-O liste_options]

(usually given in a bootscript) causes all filesystems mentioned in fstab (of the proper type and/or having or not having the proper options) to be mounted as indicated, except for those whose line contains the noauto keyword.

  • That is where one of the issues lies. When I take off the noauto or try to mount them directly, the client will hang up and I recieve a connection timed out error.
    – Greg Lamm
    Apr 26, 2021 at 14:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .