0

Some time ago I made my own „OS” based on mint(Debian Based distro). About u week ago I deleted 3rd partition with Ubuntu. Before this weekend I got BSOD on windows, so I'm stuck on mint. And here is my problem with third OS: i deleted accidentally grub. The problem is yet bigger because filesystem was btrfs. I copied all files (even system)to external drive and formatted partition with mint to ext4, then I recopied system and tried with GRUBrepair. As I saw root and sudo was locked (mint doesn’t have su by default), so I tried to repair by myself. Now system is stuck between: grub shell, busybox shell (initramfs error), live boot mint and „shell”with prompt for root password (i didnt setted up that YET). Is there a way to boot PC normally? Or i’m stuck on live-boot? I don’t have space for installing third OS (space which stayed after deleting ubuntu was joined to windows) and my PC is yet on guarantee... (yet worse but guarantee is only for physical things, OOF)🙄

PS: bios on my pc is „aptio setup utility”, there is no way to disable uefi and i can’t: boot rescueCD from pendrive and/or boot pc from external HDD. I don’t have external CD/DVD reader.

Thanks for answer (if any)

Here are all commands in busybox i can use : enter image description here

Actually I didn't have fsck. So, after lot of tries I found reiserfsck instead of fsck I don't know how to run for checking partitions. So, I added a picture of it : enter image description here

When I tried reiserfsck --check /dev/sda6 I got some error :

enter image description here Now i have another errrrrrrorrrr, I'm stuck on screen which asks me for password of non-existing user : enter image description here

17
  • Some time ago I made my own „OS While this is very tough. And, none of us know how you did this. So, your question might become more harder for us more than you think. I just can help you by saying try to install grub loader the possible way you can. For me, grub-loader is my "heart" whenever I lost it I just live with frustration, "tension" and lifeless that's why I always care of grub-loader. Keep trying to fix it. – Istiak Apr 25 at 14:13
  • busybox shell (initramfs error) I had created a question on initramfs error – Istiak Apr 25 at 14:13
  • O yeah, i saw, thx! And yes - grub’s frustrating 😂 – Hacks Norris Apr 25 at 14:43
  • 1
    ⚆ _ ⚆ now i know why i was getting iniramfs error: i was making () with every "link" to file in grub... Here is another screenshot with place where i am (both terminal place and real location) : i.postimg.cc/brWXBnvv/image.jpg , and yes - it doesn't look good because i didnt setted up root account... – Hacks Norris Apr 25 at 19:48
  • 1
    Im not sure but yet yesterday i was messing up with sudo, so... Maybe... And if about error - it's not the same i got on my pc... I had "enter root password for maintenance or press ctrl+D to continue" – Hacks Norris Apr 26 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.