2

If i try to type a capital letter with accent (e.g. Ř) in kde-konsole, I get the following result: ˇR - the letter and the accent as two characters. The normal behaviour is that after pressing ˇ character, it is not output immediately but another character is expected. In the konsole tho, the character is output immediately. In other applications, it works fine. I am using gnome and in it the kde-console application. Any directions how to solve this?

1

First check your font (Right click, Edit current profile),

Then check your encodings, i.e $LANG $LANGUAGE $LC_ALL see if it's right,

Also check the encoding in Konsole profile (Advanced tab)

Does it happen to other KDE app like kate, kwrite?

  • Font should ok be as I can copy the character in the console - just can't type it. By default I use en_US.utf8 locale but switching to mine does not help. Encoding is utf8. But yeah it seems all kde packages on my computer have this issue. I tried konqueror and the same issue appear there (I don't have kate or kwrite). – clime Feb 13 '13 at 10:34
  • hmm it does not work if konsole is run inside gnome. If I run it under kde (i have installed the whole desktop), it works correctly. Anyway at the process of trying it out in kde I again realized how incredibly cool this desktop environment is... – clime Feb 13 '13 at 12:05
1

Seems to be some kind of a bug refering to: Keyboard layout does not work correctly in konsole
Set the keyboard-layout which you use mainly (that one which works fine in other applications) to the first position in kde keyboard-layout settings, or delete all other keyboard leyouts if you don't need them anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.