0

I recently got a Raspberry Pi Zero W and loaded Kali Linux onto it.

I want to get the build in bluetooth working however I can't open the bluetooth manager. Originally it said there was an issue with bluez daemon but I then did some research and found that systemctl status bluetooth.service said bluetooth was inactive(dead).

After using modprobe btusb, enabling and starting bluetooth this became active.

When I then try to click on the bluetooth manager application nothing happens, no window opens or anything.

I then updated my system with sudo apt full-upgrade -y , this took a long time and required multiple re-logins. It didn't make a difference, I then tried opening it in terminal with bluetooth-manager, this told me that blueman applet needs to be running.

So I try running blueman-applet in terminal and this said

gi.repository.GLib.Error: g-io-error-quark: The connection is closed (18)

That is as far as I have gotten. It appears to be a problem in a python file and it may be in an unreadable directory, but I have not moved any files whatsoever since a brand new boot of kali.

All I want to do is get bluetooth running but it seems to be problem after problem. I have also tried reinstalling blueman and bluez and restarting bluetooth and the raspberry pi.

I am brand new to Linux with about a days experience so if it is possible to keep things simple and just tell me what to type into terminal if you know what the problem is, I would really appreciate it.

1
  • if you are brand new to Linux, then forget about Kali – jsotola Apr 22 at 19:24
0

I managed to get it working by using an external bluetooth dongle. There may just be conpatability issues with the pi zero version of kali and the bluetooth chip in the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.