I am trying to see the content in a boot.img file from an Android image.

I googled and found this article to extract system.img, but it doesn't work for boot.img. When trying to do this for boot.img, it is showing the following:

Invalid sparse file format at header magi
Failed to read sparse file

Is simg2img used only for extracting system.img?

  1. If so, Is there any other method to extract boot.img?
  2. If not, what is the problem for not extracting boot.img?

boot.img is a small(ish) file that contain two main parts.

          * kernel(important for android)
          * ramdisk( a core set of instruction & binaries)

Unpack boot.img:

It contains the following steps:

  1. Download the tool using wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/android-serialport-api/android_bootimg_tools.tar.gz

  2. Extract the file using tar xvzf android_bootimg_tools.tar.gz.

    It contains two binaries:

            * unpackbootimg
            * mkbootimg
  3. Then execute ./unpackbootimg -i <filename.img> -o <output_directory>

    The output_directory will contain:

    • boot.img-zImage ----> kernel
    • boot.img-ramdisk.gz ----> ramdisk

We can extract ramdisk also, using the following command

gunzip -c boot.img-ramdisk.gz | cpio -i

After changing the files, we can again pack those files as boot.img using mkbootimg

Have fun!

  • 1
    I am getting error at third step please help me...the terminal says unpackbootimg command not found
    – RMB
    Jun 17 '14 at 10:04
  • 1
    Getting the same error for step 3 on Mint 17 here. Tried running them by sudo and after chmod 755 to no avail.
    – Nisse
    Sep 11 '14 at 4:41
  • 1
    In step 3, make sure output_path already exists, otherwise unpackbootimg will segfault.
    – Aldaviva
    Feb 13 '16 at 3:07
  • 2
    The link for the tool is dead. Jan 18 '17 at 15:05
  • 1
    Fix for: "unpackbootimg command not found", you are running 32bit binary on a 64 bit machine without 32bit dependencies. Install them with "apt-get install gcc-multilib"
    – WHol
    Jul 27 '17 at 19:44

boot.img is not a compressed filesystem image like system.img. It is read by the bootloader, and contains little more than a kernel image and a ramdisk image.

Some binary distribution ship the kernel and ramdisk images separately. In that case you don't need to do anything with boot.img, just regenerate a new one with mkbootimg.

If you need to extract information from a boot.img, try split_bootimg (by William Enck, via the Android wiki).

  • The link to split_bootimg is no longer valid. Sep 28 '13 at 3:19
  • @NathanOsman Replaced by a link to the copy on William Enck's page. Sep 28 '13 at 10:10

I use opensuse. I have installed abootimg. If you want to extract (boot|recovery).img run such:

abootimg -x (boot|recovery).img

Then you get next files: bootimg.cgf, zImage and initrd.img If you want to pack image you run such

abootimg --create (boot|recovery).img -f bootimg.cfg -k zImage -r initrd.img

Then you'll get (boot|recovery).img



You can use the following tool to extract and re-pack Android boot image

$ git clone https://github.com/cfig/Android_boot_image_editor.git

copy your boot.img to the cloned git repository. Run:

$ ./gradlew unpack

First time run will need to download necessary libs from internet, be patient. You can get the contents at "build/unzip_boot/", like this:

├── bootimg.json (boot image info)
├── kernel
├── second (2nd bootloader, if exists)
├── boot.img.avb.json (AVB only)
└── root
  • This is the answer, as this code and project is current and maintained. Nov 6 '19 at 18:50
  • It no longer works for arm64, but I made an issue.
    – DUO Labs
    Sep 11 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.