1

I am over writing a particular file (called "demo") on my server and wget-ting it. However, sometimes wget retrieves an outdated file, despite my checking on the net that the file has been updated. I've tried deleting before re-writing, sometimes I even delete all the files; but when I try to wget "demo" I still get an outdated copy.

I'm running debian on a simulated MIPS malta board (basically, linux running on MIPS) if that makes a difference.

Is this a known bug and if so, is there a way around it?

  • 8
    Probably nothing to do with wget, Linux or MIPS, but with a caching proxy somewhere on your connection path that's not behaving quite properly. – Mat Feb 13 '13 at 9:10
  • 4
    wget will always download the file again unless you specify certain parameters like -N. It cannot magically retrieve a previous version. – scai Feb 13 '13 at 9:17
  • Righ,t, thank's guys. @Mat, could you point me in the direction of some material I could read up on the issue? A quick google return hits that were a little above me. – C.E.Sally Feb 13 '13 at 16:05
  • 1
    as others have said it sounds a lot like you're hitting a proxy. There may be some header you can add to your wget invocation that will request the cache to re-check the server. – Jasen Feb 16 '13 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.